summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 42dc26b..7e23d16 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -23,6 +23,25 @@ UBOOT_INITIAL_ENV = "u-boot-initial-env"
COMPATIBLE_MACHINE = "(ti-soc)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+do_compile[mcdepends] += "mc::k3r5:virtual/bootloader:do_deploy"
+
+do_compile:prepend:k3 () {
+ cp ${DEPLOY_DIR_IMAGE}/tiboot3-*.bin ${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/
+}
+
+do_deploy:append:k3 () {
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ for f in ${B}/${config}/firmware-*.bin; do
+ if [ -f "$f" ]; then
+ install -m 644 $f ${DEPLOYDIR}/
+ fi
+ done
+ done
+ fi
+}
+
do_deploy:append:k3r5 () {
# remove any u-boot-initial-env* file not already removed by the
# u-boot-ti.inc