summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/device-tree-overlays_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes-kernel/linux/device-tree-overlays_git.bb b/recipes-kernel/linux/device-tree-overlays_git.bb
index 8d30334..377bb38 100644
--- a/recipes-kernel/linux/device-tree-overlays_git.bb
+++ b/recipes-kernel/linux/device-tree-overlays_git.bb
@@ -3,9 +3,9 @@ DESCRIPTION = "Toradex BSP device tree overlays from within layer."
SRC_URI = "git://git.toradex.com/device-tree-overlays.git;branch=${SRCBRANCH};protocol=https"
-SRCBRANCH = "toradex_4.14-2.3.x-imx"
+SRCBRANCH = "toradex_5.4-2.1.x-imx"
-SRCREV = "fc95c1137968488a172c45dc66813fd3e79286e8"
+SRCREV = "9588d2f52965826d60e839828ab8408903c75549"
SRCREV_use-head-next = "${AUTOREV}"
PV = "${SRCBRANCH}+git${SRCPV}"
@@ -15,3 +15,13 @@ inherit devicetree
S = "${WORKDIR}/git/overlays"
COMPATIBLE_MACHINE = ".*(mx[678]).*"
+
+# we have dtbo's in arm and arm64 architecture, set the include paths
+# to include both architectures.
+KERNEL_INCLUDE = " \
+ ${STAGING_KERNEL_DIR}/arch/arm/boot/dts \
+ ${STAGING_KERNEL_DIR}/arch/arm/boot/dts*/* \
+ ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts \
+ ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/* \
+ ${STAGING_KERNEL_DIR}/scripts/dtc/include-prefixes \
+"