summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend2
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend2
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend12
-rw-r--r--recipes-graphics/drm/libdrm_2.4.%.imx.bbappend2
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5%.bbappend14
5 files changed, 16 insertions, 16 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
index 46d018a..aa11763 100644
--- a/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG:remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', 'xcomposite-egl xcomposite-glx', '', d)}" \ No newline at end of file
+PACKAGECONFIG:remove:tdx = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', 'xcomposite-egl xcomposite-glx', '', d)}"
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
index 324b51b..2e98523 100644
--- a/recipes-bsp/alsa-state/alsa-state.bbappend
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -1,4 +1,4 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/alsa-state/:"
#make this machine specific, as we have different codecs with different settings
-PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGE_ARCH:tdx = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index f8fbddd..723f478 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -1,10 +1,10 @@
-PV = "2.2+git${SRCPV}"
-SRCBRANCH = "toradex_imx_5.4.70_2.3.0"
-SRCREV = "835a8f67b2ca7aa3f2d05d6e6a1a51f7e1147266"
-SRCREV:use-head-next = "${AUTOREV}"
-SRC_URI = "git://git.toradex.com/imx-atf.git;protocol=https;branch=${SRCBRANCH}"
+PV:tdx = "2.2+git${SRCPV}"
+SRCBRANCH:tdx = "toradex_imx_5.4.70_2.3.0"
+SRCREV:tdx = "835a8f67b2ca7aa3f2d05d6e6a1a51f7e1147266"
+SRCREV:use-head-next:tdx = "${AUTOREV}"
+SRC_URI:tdx = "git://git.toradex.com/imx-atf.git;protocol=https;branch=${SRCBRANCH}"
-EXTRA_OEMAKE:append = " \
+EXTRA_OEMAKE:append:tdx = " \
BUILD_STRING="${SRCBRANCH}-g${@'${SRCPV}'.replace('AUTOINC+', '')}" \
"
EXTRA_OEMAKE:append:verdin-imx8mm = " \
diff --git a/recipes-graphics/drm/libdrm_2.4.%.imx.bbappend b/recipes-graphics/drm/libdrm_2.4.%.imx.bbappend
index d594682..aa86fd5 100644
--- a/recipes-graphics/drm/libdrm_2.4.%.imx.bbappend
+++ b/recipes-graphics/drm/libdrm_2.4.%.imx.bbappend
@@ -1 +1 @@
-RRECOMMENDS:${PN}:append:imxgpu = " ${PN}-vivante"
+RRECOMMENDS:${PN}:append:imxgpu:tdx = " ${PN}-vivante"
diff --git a/recipes-kernel/linux/linux-imx-headers_5%.bbappend b/recipes-kernel/linux/linux-imx-headers_5%.bbappend
index ab58e84..259f6a2 100644
--- a/recipes-kernel/linux/linux-imx-headers_5%.bbappend
+++ b/recipes-kernel/linux/linux-imx-headers_5%.bbappend
@@ -1,8 +1,8 @@
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-SRCBRANCH = "toradex_5.4-2.1.x-imx"
-LOCALVERSION = "-2.3.2"
-SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=https;branch=${SRCBRANCH}"
+LIC_FILES_CHKSUM:tdx = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+SRCBRANCH:tdx = "toradex_5.4-2.1.x-imx"
+LOCALVERSION:tdx = "-2.3.2"
+SRC_URI:tdx = "git://git.toradex.com/linux-toradex.git;protocol=https;branch=${SRCBRANCH}"
# Keep that one stable, i.e. use the exact git hash from the NXP BSP.
-SRCREV = "dea2fede7e024ee7029b13e8d82a00ec14427777"
-PV = "5.4"
-IMX_UAPI_HEADERS:remove = "imx_vpu.h"
+SRCREV:tdx = "dea2fede7e024ee7029b13e8d82a00ec14427777"
+PV:tdx = "5.4"
+IMX_UAPI_HEADERS:remove:tdx = "imx_vpu.h"