summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-05-18 17:20:41 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-05-18 17:24:44 +0200
commit1c5100bc8f320678e048a551cad229d088199b3a (patch)
treeaf30490bad389f8f27e0b077d6e7f2c21cc3f352 /recipes-kernel/linux
parent0414b79e8e860407b783548170a2d227c7f51df7 (diff)
linux-imx-headers_5%.bbappend: keep deploying ion.h
meta-freescale moved to a newer kernel which no longer deploys ion.h. This no leads in our setup to a build failure. Override that for our 5.4 kernel setup. Prevents for imx-vpu-hantro build: | decoder_sw/software/linux/dwl/dwl_linux.c:53:10: fatal error: linux/ion.h: No such file or directory | 53 | #include <linux/ion.h> | | ^~~~~~~~~~~~~ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_5%.bbappend b/recipes-kernel/linux/linux-imx-headers_5%.bbappend
index 259f6a2..da31640 100644
--- a/recipes-kernel/linux/linux-imx-headers_5%.bbappend
+++ b/recipes-kernel/linux/linux-imx-headers_5%.bbappend
@@ -6,3 +6,12 @@ SRC_URI:tdx = "git://git.toradex.com/linux-toradex.git;protocol=https;branch=${S
SRCREV:tdx = "dea2fede7e024ee7029b13e8d82a00ec14427777"
PV:tdx = "5.4"
IMX_UAPI_HEADERS:remove:tdx = "imx_vpu.h"
+
+do_install:append:tdx() {
+ # FIXME: The ion.h is still on staging so "promote" it for now
+ # and install it by hand
+ cp ${S}/drivers/staging/android/uapi/ion.h ${S}${includedir}/linux
+ install -D -m 0644 ${S}/drivers/staging/android/uapi/ion.h \
+ ${D}${includedir}/imx/linux/ion.h
+
+}