summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb
diff options
context:
space:
mode:
authorEmanuele Ghidoli <emanuele.ghidoli@toradex.com>2023-09-04 12:14:38 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-09-12 11:27:40 -0300
commit44ec302ce45a2cc04349a84bafc9a0b0ac579040 (patch)
tree8a16cb798655aa75766cf85d223cbf13a1a3cac3 /recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb
parentfb2af4fd2041d7e9833c73077348fecf7260d789 (diff)
linux-toradex: update to toradex_5.15-2.2.x-imx
Update the downstream kernel (NXP fork) to lf-5.15-2.2.0 plus fslc stable patches merges. Then rebase our 5.15-2.1.0 on top of it [1]. For the RT kernel, set the matching RT patch. [1] https://github.com/Freescale/linux-fslc/commit/7c13adcd3af7dcd541144655102e1cdb941ad538 Related-to: ELB-5185 Signed-off-by: Emanuele Ghidoli <emanuele.ghidoli@toradex.com> (cherry picked from commit 65db2ad74d40b30e4ea1421ce699cad62d08b0a8)
Diffstat (limited to 'recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb b/recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb
new file mode 100644
index 0000000..eb47818
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_5.15-2.2.x.bb
@@ -0,0 +1,50 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-${PV}:"
+require recipes-kernel/linux/linux-imx.inc
+
+SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
+SUMMARY:preempt-rt = "Real-Time Linux kernel for Toradex Freescale i.MX based modules"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+SRC_URI = " \
+ git://git.toradex.com/linux-toradex.git;protocol=https;branch=${SRCBRANCH};name=machine \
+"
+
+# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
+KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
+
+inherit toradex-kernel-deploy-config toradex-kernel-localversion
+LINUX_VERSION = "5.15.125"
+# skip, as with use-head-next LINUX_VERSION might be set wrongly
+KERNEL_VERSION_SANITY_SKIP = "1"
+
+SRCBRANCH = "toradex_5.15-2.2.x-imx"
+SRCREV_machine = "626df3983254bccebc2584b90e615ad89f79cf46"
+SRCREV_machine:use-head-next = "${AUTOREV}"
+
+DEPENDS += "bc-native"
+COMPATIBLE_MACHINE = "mx8-nxp-bsp"
+
+KBUILD_DEFCONFIG:mx8-nxp-bsp ?= "toradex_defconfig"
+
+export DTC_FLAGS = "-@"
+
+###############################################################################
+# Apply the RT patch and change the configuration to use PREMPT_RT when the
+# preempt-rt override is set.
+###############################################################################
+
+# patches get moved into the 'older' directory when superseeded, so provide
+# both possible storage locations.
+MIRRORS:append:preempt-rt = "${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.15/older/ ${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.15/"
+SRC_URI:append:preempt-rt = " \
+ file://0001-Revert-Revert-ARM-9113-1-uaccess-remove-set_fs-imple.patch \
+ file://0002-arch-arm-Kconfig-prepare-for-rt-patch.patch \
+ ${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.15/older/patch-5.15.125-rt66.patch.xz;name=rt-patch \
+ file://0004-Revert-arch-arm-Kconfig-prepare-for-rt-patch.patch \
+ file://0005-Revert-Revert-Revert-ARM-9113-1-uaccess-remove-set_f.patch \
+ file://preempt-rt.scc \
+ file://preempt-rt-less-latency.scc \
+"
+
+SRC_URI[rt-patch.sha256sum] = "4bb33ab169af60e7f7f6b835e91aa0c17ce4563b00a3c1b35800258f9b678d46"