summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:08:24 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:11:41 +0200
commit6ea5ec96855a2b6c071dad7f24d15dbd3535d2a3 (patch)
tree6b03ab654fb950ad1c95b5363972dc64e05e6f23 /recipes-bsp/u-boot
parentbfee96400a603e7c8bcd26e9bbb723910508a072 (diff)
layer: convert to new override syntax
This is the result of automated script (0.9.3) conversion: +# meta-toradex-distro +vars = vars + ["preempt-rt","tdx","upstream"] +# meta-toradex-* machines +vars = vars + ["apalis-","colibri-","verdin-","tegra124"] +# meta-freescale +vars = vars + ["imx","mx6","mx7","mx8","use-mainline-bsp","use-nxp-bsp"] ../openembedded-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2020.04.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2020.07.bb10
4 files changed, 9 insertions, 9 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common.inc b/recipes-bsp/u-boot/u-boot-toradex-common.inc
index 2b457f3..812f779 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-common.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-common.inc
@@ -25,7 +25,7 @@ S = "${WORKDIR}/git"
UBOOT_INITIAL_ENV = "u-boot-initial-env"
-do_deploy_append_mx8m() {
+do_deploy:append:mx8m() {
# Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
if [ -n "${UBOOT_CONFIG}" ]
then
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc b/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
index 920aae0..f3c289f 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
@@ -12,7 +12,7 @@ SRC_URI = " \
SRCREV = "f499632b31f88dbd313fe9f742e2019c56032558"
SRCREV_use-head-next = "${AUTOREV}"
-SRCBRANCH = "toradex_imx_v2020.04_5.4.70_2.3.0"
+SRCBRANCH = "toradex:imx_v2020.04_5.4.70_2.3.0"
S = "${WORKDIR}/git"
@@ -23,7 +23,7 @@ UBOOT_INITIAL_ENV = "u-boot-initial-env"
COMPATIBLE_MACHINE = "(mx8)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_deploy_append_mx8m() {
+do_deploy:append:mx8m() {
# Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
if [ -n "${UBOOT_CONFIG}" ]
then
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2020.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2020.04.bb
index 47630b1..c301226 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2020.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2020.04.bb
@@ -6,6 +6,6 @@ SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
B = "${WORKDIR}/build"
PROVIDES += "u-boot"
-DEPENDS_append = " dtc-native"
+DEPENDS:append = " dtc-native"
BOOT_TOOLS = "imx-boot-tools"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
index f965e28..e623486 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
@@ -10,8 +10,8 @@ DEPENDS += "bc-native dtc-native"
# While NXP i.MX 7 downstream requires the Linux kernel to boot in secure
# mode mainline/upstream requires non-secure mode instead, as it properly
# uses PSCI to control further cores.
-SRC_URI_append_use-mainline-bsp_colibri-imx7 = " file://0001-colibri_imx7-boot-linux-kernel-in-non-secure-mode.patch"
-SRC_URI_append_use-mainline-bsp_colibri-imx7-emmc = " file://0001-colibri_imx7-boot-linux-kernel-in-non-secure-mode.patch"
+SRC_URI:append:use-mainline-bsp:colibri-imx7 = " file://0001-colibri:imx7-boot-linux-kernel-in-non-secure-mode.patch"
+SRC_URI:append:use-mainline-bsp:colibri-imx7-emmc = " file://0001-colibri:imx7-boot-linux-kernel-in-non-secure-mode.patch"
BOOT_TOOLS = "imx-boot-tools"
@@ -31,14 +31,14 @@ nand_padding () {
dd bs=1024 count=1 if=/dev/zero | cat - ${PADDING_DIR}/u-boot.imx.zero-padded > ${PADDING_DIR}/u-boot-nand.imx
}
-do_compile_append_colibri-imx6ull () {
+do_compile:append:colibri-imx6ull () {
nand_padding
}
-do_compile_append_colibri-imx7 () {
+do_compile:append:colibri-imx7 () {
nand_padding
}
-do_compile_append_colibri-vf () {
+do_compile:append:colibri-vf () {
nand_padding
}