summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-08-05 19:25:20 +0200
committerMing Liu <ming.liu@toradex.com>2020-08-10 15:45:03 +0200
commit7c758ad91693bac28796d8e7b9d27c15f89b6cac (patch)
treeb656eb1940fccffddb81e23fcdfb92c9fded4c67 /recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
parent8a2e5df0404ac59a5f1e74638a4220274afb4867 (diff)
meta: change to use libubootenv to provide u-boot-fw-utils
The changes include: - Drop PREFERRED_PROVIDER_u-boot-fw-utils from machine conf. - Drop u-boot-toradex-fw-utils recipes. - Drop fw_unlock_mmc.sh, that's not needed for libubootenv. - Drop u-boot.inc, use default u-boot.inc from OE layer. - Add fw_env.config to uboot recipe. - Set UBOOT_INITIAL_ENV to u-boot-initial-env, which is being referred in libubootenv. Related-to: ELB-2552 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb52
1 files changed, 0 insertions, 52 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
deleted file mode 100644
index 2c46a73..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2018.03.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-require u-boot-toradex-common_${PV}.inc
-
-SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-DEPENDS += "mtd-utils"
-
-SRC_URI += " \
- file://fw_env.config \
- file://fw_unlock_mmc.sh \
-"
-
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
-
-inherit uboot-config
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake envtools
-}
-
-install_unlock_emmc() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
-}
-
-do_install_append_mx8() {
- install_unlock_emmc
-}
-
-do_install () {
- install -d ${D}${base_sbindir}
- install -d ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
-}
-
-do_install_class-cross () {
- install -d ${D}${bindir_cross}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
-}
-
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
-
-PROVIDES += "u-boot-fw-utils"
-RPROVIDES_${PN} += "u-boot-fw-utils"
-
-COMPATIBLE_MACHINE = "(mx8)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-BBCLASSEXTEND = "cross"