summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-17 12:23:18 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-17 13:07:01 +0200
commit02e6c65c9e44dc12e66eff1fbaef1767d83e1556 (patch)
treeb1ea9de95d8c6186fba05a715ac625ed87935bdc /recipes-bsp
parent7ed1498534836668a9070614c6dd5a70ccaf394a (diff)
firmware-imx: vpu: create symlinks for older kernelsHEADmaster
Kernel 6.5+ loads the Amphion VPU firmware from a different path. See commit dcff0b56f661 ("media: amphion: Fix firmware path to match linux-firmware)" Create a symlink at the old locatation to allow older kernels to load the firmware too. Related-to: ELB-5766 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx_%.bbappend b/recipes-bsp/firmware-imx/firmware-imx_%.bbappend
new file mode 100644
index 0000000..e26d6e6
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-imx_%.bbappend
@@ -0,0 +1,8 @@
+# create symlinks for the amphion vpu fw where older kernel
+# try to load them from.
+do_install:append () {
+ install -d ${D}${nonarch_base_libdir}/firmware/vpu
+ ln -sf ../amphion/vpu/vpu_fw_imx8_dec.bin ${D}${nonarch_base_libdir}/firmware/vpu/
+ ln -sf ../amphion/vpu/vpu_fw_imx8_enc.bin ${D}${nonarch_base_libdir}/firmware/vpu/
+}
+FILES:${PN}-vpu-amphion:append = " ${nonarch_base_libdir}/firmware/vpu/vpu_fw_imx8*"