summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-08-07 14:49:43 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-09-12 11:27:40 -0300
commitfb2af4fd2041d7e9833c73077348fecf7260d789 (patch)
treee64288c77a70890327799e5b2ae7637a2cd04927
parentc3897799d04f21f962272e88af185ecd357d9f3d (diff)
u-boot-toradex: merge .inc file into recipe
The file u-boot-toradex-common_2022.04.inc is only used in u-boot-toradex_2022.04.bb. Having the information spread over two files reduces clarity. Additionally our current way of updating SRCREV with CI/CD is not able to update the SRCREV in *.inc file if pulled in through relative path. Related-to: ELB-5266 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 69bbd0e41af0689f8d6185aae4bf46f6173ddc59) (cherry picked from commit f62e8915300f5f98849e8336eedc991074a1f402) Squashed the fixes commit. Followed meta-frescale changes about choosing between binman and imx-mkimage. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common_2022.04.inc44
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.04.bb48
2 files changed, 42 insertions, 50 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common_2022.04.inc b/recipes-bsp/u-boot/u-boot-toradex-common_2022.04.inc
deleted file mode 100644
index d271008..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-common_2022.04.inc
+++ /dev/null
@@ -1,44 +0,0 @@
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-DEPENDS += "flex-native bison-native"
-
-LICENSE = "GPL-2.0-or-later"
-LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-
-SRCREV = "c71ae7141f30da99e2206a331ac821603f238fa7"
-SRCREV:use-head-next = "${AUTOREV}"
-SRCBRANCH = "toradex_imx_lf_v2022.04"
-
-S = "${WORKDIR}/git"
-
-inherit toradex-u-boot-localversion
-# build imx-boot from within U-Boot
-inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
-
-COMPATIBLE_MACHINE = "(mx8-generic-bsp)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_deploy:append:mx8m-generic-bsp() {
- # Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
- fi
- done
- unset j
- done
- unset i
- fi
-}
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
index e39c1bb..2215977 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
@@ -1,13 +1,49 @@
+SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
+HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
+SECTION = "bootloaders"
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "bc-native dtc-native flex-native bison-native python3-setuptools-native"
+PROVIDES:append = " u-boot"
+
require recipes-bsp/u-boot/u-boot.inc
-require recipes-bsp/u-boot/u-boot-toradex-common_${PV}.inc
-SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
+SRCREV = "7bd2074193e156358adc5b5065c690371cf78231"
+SRCREV:use-head-next = "${AUTOREV}"
+SRCBRANCH = "toradex_imx_lf_v2022.04"
+S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
-PROVIDES += "u-boot"
-DEPENDS += "bc-native dtc-native python3-setuptools-native"
-
BOOT_TOOLS = "imx-boot-tools"
-SRCREV = "7bd2074193e156358adc5b5065c690371cf78231"
+inherit toradex-u-boot-localversion
+# build imx-boot from within U-Boot
+inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
+
+UBOOT_INITIAL_ENV = "u-boot-initial-env"
+
+COMPATIBLE_MACHINE = "(mx8-generic-bsp)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_deploy:append:mx8m-generic-bsp() {
+ # Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ i=$(expr $i + 1);
+ for type in ${UBOOT_CONFIG}; do
+ j=$(expr $j + 1);
+ if [ $j -eq $i ]
+ then
+ install -d ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
+ fi
+ done
+ unset j
+ done
+ unset i
+ fi
+}