summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-06-22 09:41:38 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-10-09 22:05:06 +0200
commit5e0a215797a708fffef17edf88d1df1c4dd207ce (patch)
treeb1089ddf9c7c1178c83aa9dc16b56209a2cc3162
parentd4e72171f173b14d7c0f8418dc520de6eef6396b (diff)
remove upgrades which are now in meta-freescale
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend12
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend14
-rw-r--r--recipes-bsp/imx-mkimage/imx-mkimage_git.bbappend2
-rw-r--r--recipes-graphics/wayland/wayland-protocols_1.13.imx.bbappend6
-rw-r--r--recipes-kernel/linux/linux-imx-headers_4.9.123.bbappend5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch167
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend2
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend3
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend4
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend4
13 files changed, 0 insertions, 228 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
deleted file mode 100644
index c48fb6b..0000000
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
-PV = "1.5.0+git${SRCPV}"
-SRCBRANCH = "imx_4.14.78_1.0.0_ga"
-SRCREV = "d6451cc1e162eff89b03dd63e86d55b9baa8885b"
-
-PLATFORM_mx8qxp = "imx8qxp"
-
-# imx-atf 1.5 uses bl31-imx8qxp.bin, 2.0 will use bl31-imx8qx.bin for a
-# platform specific filename. Provide both for now, so that the user of
-# the file need not care.
-do_deploy_append_mx8qxp () {
- install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-imx8qx.bin
-}
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
deleted file mode 100644
index 86abe51..0000000
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-ATF_MACHINE_NAME_mx8qxp = "bl31-imx8qx.bin"
-SRCBRANCH = "imx_4.14.98_2.0.0_ga"
-SRCREV = "dd0234001713623c79be92b60fa88bc07b07f24f"
-
-deploy_mx8() {
- install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
-}
-deploy_mx8x() {
- install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
-}
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bbappend b/recipes-bsp/imx-mkimage/imx-mkimage_git.bbappend
deleted file mode 100644
index 636494f..0000000
--- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-SRCBRANCH = "imx_4.14.98_2.0.0_ga"
-SRCREV = "dd0234001713623c79be92b60fa88bc07b07f24f"
diff --git a/recipes-graphics/wayland/wayland-protocols_1.13.imx.bbappend b/recipes-graphics/wayland/wayland-protocols_1.13.imx.bbappend
deleted file mode 100644
index 7d4199e..0000000
--- a/recipes-graphics/wayland/wayland-protocols_1.13.imx.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-PV = "1.16.imx"
-WAYLAND_PROTOCOLS_SRC ?= "git://source.codeaurora.org/external/imx/wayland-protocols-imx.git;protocol=https"
-SRCBRANCH = "wayland-protocols-imx-1.16"
-SRC_URI = "${WAYLAND_PROTOCOLS_SRC};branch=${SRCBRANCH} "
-SRCREV = "e05c19d9520f0b1289cf0844d6e2f877114f39d5"
-S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/linux-imx-headers_4.9.123.bbappend b/recipes-kernel/linux/linux-imx-headers_4.9.123.bbappend
deleted file mode 100644
index f03fb15..0000000
--- a/recipes-kernel/linux/linux-imx-headers_4.9.123.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-PV = "4.14.98"
-SRCBRANCH = "imx_4.14.98_2.0.0_ga"
-LOCALVERSION = "-${SRCBRANCH}"
-SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "dfc78102d29f81d9316b281a3b8af3dff95174c8"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
deleted file mode 100644
index 6cbf33b..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
-SRCREV = "0191521ba226904e4b2f84c38e5f6ae75169a18a"
-SRC_URI_remove ="file://0001-opencv-fix-build-for-opencv-3-4-2.patch" \ No newline at end of file
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
deleted file mode 100644
index bcada34..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
+++ /dev/null
@@ -1,167 +0,0 @@
-From 7022b87353a37b78bae7cf0106a4e47913bb5c97 Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Thu, 5 Apr 2018 10:15:08 +0800
-Subject: [PATCH] Makefile.am: don't hardcode libtool name when running
- introspection tools
-
-Upstream-Status: Pending [review on oe-core maillist]
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
-Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-
----
- gst-libs/gst/allocators/Makefile.am | 2 +-
- gst-libs/gst/app/Makefile.am | 2 +-
- gst-libs/gst/audio/Makefile.am | 2 +-
- gst-libs/gst/gl/Makefile.am | 2 +-
- gst-libs/gst/pbutils/Makefile.am | 2 +-
- gst-libs/gst/riff/Makefile.am | 2 +-
- gst-libs/gst/rtp/Makefile.am | 2 +-
- gst-libs/gst/rtsp/Makefile.am | 2 +-
- gst-libs/gst/sdp/Makefile.am | 2 +-
- gst-libs/gst/tag/Makefile.am | 2 +-
- gst-libs/gst/video/Makefile.am | 2 +-
- 11 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/gst-libs/gst/allocators/Makefile.am b/gst-libs/gst/allocators/Makefile.am
-index 1957d28..1ecc950 100644
---- a/gst-libs/gst/allocators/Makefile.am
-+++ b/gst-libs/gst/allocators/Makefile.am
-@@ -42,7 +42,7 @@ GstAllocators-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstallocators-@
- --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \
- --library=libgstallocators-@GST_API_VERSION@.la \
- --include=Gst-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg-export gstreamer-allocators-@GST_API_VERSION@ \
- --output $@ \
-diff --git a/gst-libs/gst/app/Makefile.am b/gst-libs/gst/app/Makefile.am
-index 52f6ad3..5bfd606 100644
---- a/gst-libs/gst/app/Makefile.am
-+++ b/gst-libs/gst/app/Makefile.am
-@@ -56,7 +56,7 @@ GstApp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstapp-@GST_API_VERSIO
- --library=libgstapp-@GST_API_VERSION@.la \
- --include=Gst-@GST_API_VERSION@ \
- --include=GstBase-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-base-@GST_API_VERSION@ \
- --pkg-export gstreamer-app-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/audio/Makefile.am b/gst-libs/gst/audio/Makefile.am
-index 2922245..7fb65f2 100644
---- a/gst-libs/gst/audio/Makefile.am
-+++ b/gst-libs/gst/audio/Makefile.am
-@@ -184,7 +184,7 @@ GstAudio-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstaudio-@GST_API_VE
- --include=Gst-@GST_API_VERSION@ \
- --include=GstBase-@GST_API_VERSION@ \
- --include=GstTag-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-base-@GST_API_VERSION@ \
- --pkg-export gstreamer-audio-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/gl/Makefile.am b/gst-libs/gst/gl/Makefile.am
-index 4e77e8c..3276d7f 100644
---- a/gst-libs/gst/gl/Makefile.am
-+++ b/gst-libs/gst/gl/Makefile.am
-@@ -193,7 +193,7 @@ GstGL-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstgl-@GST_API_VERSION@
- --include=Gst-@GST_API_VERSION@ \
- --include=GstBase-@GST_API_VERSION@ \
- --include=GstVideo-@GST_API_VERSION@ \
-- --libtool="${LIBTOOL}" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-base-@GST_API_VERSION@ \
- --pkg gstreamer-video-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/pbutils/Makefile.am b/gst-libs/gst/pbutils/Makefile.am
-index ae51993..35a6e44 100644
---- a/gst-libs/gst/pbutils/Makefile.am
-+++ b/gst-libs/gst/pbutils/Makefile.am
-@@ -103,7 +103,7 @@ GstPbutils-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstpbutils-@GST_AP
- --include=GstTag-@GST_API_VERSION@ \
- --include=GstVideo-@GST_API_VERSION@ \
- --include=GstAudio-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-tag-@GST_API_VERSION@ \
- --pkg gstreamer-video-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/riff/Makefile.am b/gst-libs/gst/riff/Makefile.am
-index fb53f06..e66ef4f 100644
---- a/gst-libs/gst/riff/Makefile.am
-+++ b/gst-libs/gst/riff/Makefile.am
-@@ -49,7 +49,7 @@ libgstriff_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS)
- # --include=GstAudio-@GST_API_VERSION@ \
- # --include=GstTag-@GST_API_VERSION@ \
- # --include=Gst-@GST_API_VERSION@ \
--# --libtool="$(top_builddir)/libtool" \
-+# --libtool="$(LIBTOOL)" \
- # --pkg gstreamer-@GST_API_VERSION@ \
- # --pkg gstreamer-tag-@GST_API_VERSION@ \
- # --pkg gstreamer-audio-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/rtp/Makefile.am b/gst-libs/gst/rtp/Makefile.am
-index a6f971d..77ebeeb 100644
---- a/gst-libs/gst/rtp/Makefile.am
-+++ b/gst-libs/gst/rtp/Makefile.am
-@@ -69,7 +69,7 @@ GstRtp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstrtp-@GST_API_VERSIO
- --library=libgstrtp-@GST_API_VERSION@.la \
- --include=Gst-@GST_API_VERSION@ \
- --include=GstBase-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-base-@GST_API_VERSION@ \
- --pkg-export gstreamer-rtp-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/rtsp/Makefile.am b/gst-libs/gst/rtsp/Makefile.am
-index ceb07f4..db9d0fd 100644
---- a/gst-libs/gst/rtsp/Makefile.am
-+++ b/gst-libs/gst/rtsp/Makefile.am
-@@ -76,7 +76,7 @@ GstRtsp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstrtsp-@GST_API_VERS
- --include=Gio-2.0 \
- --include=Gst-@GST_API_VERSION@ \
- --include=GstSdp-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gio-2.0 \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-sdp-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/sdp/Makefile.am b/gst-libs/gst/sdp/Makefile.am
-index e197e9b..6e05cc7 100644
---- a/gst-libs/gst/sdp/Makefile.am
-+++ b/gst-libs/gst/sdp/Makefile.am
-@@ -34,7 +34,7 @@ GstSdp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstsdp-@GST_API_VERSIO
- --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \
- --library=libgstsdp-@GST_API_VERSION@.la \
- --include=Gst-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg-export gstreamer-sdp-@GST_API_VERSION@ \
- --output $@ \
-diff --git a/gst-libs/gst/tag/Makefile.am b/gst-libs/gst/tag/Makefile.am
-index 0247c33..c86515b 100644
---- a/gst-libs/gst/tag/Makefile.am
-+++ b/gst-libs/gst/tag/Makefile.am
-@@ -66,7 +66,7 @@ GstTag-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgsttag-@GST_API_VERSIO
- --library=libgsttag-@GST_API_VERSION@.la \
- --include=Gst-@GST_API_VERSION@ \
- --include=GstBase-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-base-@GST_API_VERSION@ \
- --pkg-export gstreamer-tag-@GST_API_VERSION@ \
-diff --git a/gst-libs/gst/video/Makefile.am b/gst-libs/gst/video/Makefile.am
-index 9fc1ccf..0f8455f 100644
---- a/gst-libs/gst/video/Makefile.am
-+++ b/gst-libs/gst/video/Makefile.am
-@@ -124,7 +124,7 @@ GstVideo-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstvideo-@GST_API_VE
- --library=libgstvideo-@GST_API_VERSION@.la \
- --include=Gst-@GST_API_VERSION@ \
- --include=GstBase-@GST_API_VERSION@ \
-- --libtool="$(top_builddir)/libtool" \
-+ --libtool="$(LIBTOOL)" \
- --pkg gstreamer-@GST_API_VERSION@ \
- --pkg gstreamer-base-@GST_API_VERSION@ \
- --pkg-export gstreamer-video-@GST_API_VERSION@ \
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
deleted file mode 100644
index 337c5d5..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-plugins-base:"
-SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
-SRCREV = "f62f8ab685e549eefaecdb1e700239a5a408fcad"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
deleted file mode 100644
index 9a888c5..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
-SRCREV = "a31aabb7581d3f491cd31889d44479bb0f34990b"
-
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend
deleted file mode 100644
index 6df7d19..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
-SRCREV = "d42548da09724ad8cc1aa4f1944607920be2f4c0"
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend
deleted file mode 100644
index e0ec1ba..0000000
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-PV = "4.4.5"
-SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
-SRCREV = "0c5f48b3aee473d8c8f3e853eb2078f054caa4d2"
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend
deleted file mode 100644
index 83306d2..0000000
--- a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-PV = "4.4.5"
-LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
-SRC_URI[md5sum] = "e17258161c84530097f6f9d5d46e6c26"
-SRC_URI[sha256sum] = "b53eeada02ab09c8f5216348c667f8d8edef0c585e4b2f738e8b18955ad710b4"
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend
deleted file mode 100644
index bd4b0d2..0000000
--- a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-PV = "4.4.5"
-LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
-SRC_URI[md5sum] = "7fa7b0fa1682cae71c3a163da866f676"
-SRC_URI[sha256sum] = "de86b57b429c0e6ed6b6842e5af1ec4d7b9d2074234769de6ba2edf04c967acd"