summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-02-23 15:19:00 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2022-04-26 13:19:40 +0200
commit54f74a33900cc877da8e9c79f28286903acb3db5 (patch)
treef7c84734d72510872fa401a5414716c39bba6a0d
parent25938e4adab2f1b74ba8724d7a8800fc9e3eb928 (diff)
firmware-imx-8: drop a Toradex specific fix
We dont have to install HDMI firmwares to firmware-imx-8 main package any more, they are now already in firmware-imx-hdmi subpackage. Related-to: ELB-3046 Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit 4e347e7ea7e615cc4eedaa6e25ad700fa2ed2bcc)
-rw-r--r--conf/machine/apalis-imx8.conf4
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend14
2 files changed, 1 insertions, 17 deletions
diff --git a/conf/machine/apalis-imx8.conf b/conf/machine/apalis-imx8.conf
index a6d3062..ba7b657 100644
--- a/conf/machine/apalis-imx8.conf
+++ b/conf/machine/apalis-imx8.conf
@@ -64,9 +64,7 @@ PREFERRED_PROVIDER_u-boot = "u-boot-toradex"
# not yet available in 2020.07.
PREFERRED_VERSION_u-boot-toradex = "2020.04%"
-MACHINE_FIRMWARE:append = " linux-firmware-pcie8997"
-MACHINE_FIRMWARE:append = " firmware-imx-vpu-imx8"
-MACHINE_FIRMWARE:append = " firmware-imx-8"
+MACHINE_FIRMWARE:append = " linux-firmware-pcie8997 firmware-imx-hdmi firmware-imx-vpu-imx8"
IMXBOOT_TARGETS = "flash_b0"
IMX_BOOT_SOC_TARGET = "iMX8QM"
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend b/recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend
deleted file mode 100644
index 99a3532..0000000
--- a/recipes-bsp/firmware-imx/firmware-imx-8_8.%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILES:${PN} += " \
- ${nonarch_base_libdir}/firmware/imx/hdmi/hdmitxfw.bin \
- ${nonarch_base_libdir}/firmware/imx/hdmi/hdmirxfw.bin \
- ${nonarch_base_libdir}/firmware/imx/hdmi/dpfw.bin \
-"
-
-unset do_install[noexec]
-
-do_install:append () {
- install -d ${D}${nonarch_base_libdir}/firmware/imx/hdmi
- install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi/
- install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi/
- install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi/
-}