summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-07 17:51:40 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-07 17:53:26 +0200
commit58ff29c31044c7d9b69fa2e88c8a9367b1c380e6 (patch)
treee2dbfa6b9884482ec8e2f70225491e6f94a86a90 /recipes-support
parent786d16cdc664b8941399e70aa946e619cfed9d56 (diff)
gpio-tool: remove x11 only tool
This binaries are linked against libgdk-x11, libgtk-x11 and are thus no longer usable. Remove the recipe and the binaries. Related-to: ELB-5740 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-support')
-rwxr-xr-xrecipes-support/gpio-tool/files/apalis-imx6/gpio-toolbin480284 -> 0 bytes
-rwxr-xr-xrecipes-support/gpio-tool/files/colibri-imx6/gpio-toolbin480284 -> 0 bytes
-rwxr-xr-xrecipes-support/gpio-tool/files/colibri-imx6ull/gpio-toolbin505492 -> 0 bytes
l---------recipes-support/gpio-tool/files/colibri-imx7-emmc/gpio-tool1
-rwxr-xr-xrecipes-support/gpio-tool/files/colibri-imx7/gpio-toolbin505516 -> 0 bytes
-rwxr-xr-xrecipes-support/gpio-tool/files/gpio-toolbin5320 -> 0 bytes
-rw-r--r--recipes-support/gpio-tool/files/gpio-tool.desktop11
-rw-r--r--recipes-support/gpio-tool/files/gpio-tool.pngbin340 -> 0 bytes
-rw-r--r--recipes-support/gpio-tool/gpio-tool.bb32
9 files changed, 0 insertions, 44 deletions
diff --git a/recipes-support/gpio-tool/files/apalis-imx6/gpio-tool b/recipes-support/gpio-tool/files/apalis-imx6/gpio-tool
deleted file mode 100755
index 7011019..0000000
--- a/recipes-support/gpio-tool/files/apalis-imx6/gpio-tool
+++ /dev/null
Binary files differ
diff --git a/recipes-support/gpio-tool/files/colibri-imx6/gpio-tool b/recipes-support/gpio-tool/files/colibri-imx6/gpio-tool
deleted file mode 100755
index f80347f..0000000
--- a/recipes-support/gpio-tool/files/colibri-imx6/gpio-tool
+++ /dev/null
Binary files differ
diff --git a/recipes-support/gpio-tool/files/colibri-imx6ull/gpio-tool b/recipes-support/gpio-tool/files/colibri-imx6ull/gpio-tool
deleted file mode 100755
index 77d4fa6..0000000
--- a/recipes-support/gpio-tool/files/colibri-imx6ull/gpio-tool
+++ /dev/null
Binary files differ
diff --git a/recipes-support/gpio-tool/files/colibri-imx7-emmc/gpio-tool b/recipes-support/gpio-tool/files/colibri-imx7-emmc/gpio-tool
deleted file mode 120000
index 7616811..0000000
--- a/recipes-support/gpio-tool/files/colibri-imx7-emmc/gpio-tool
+++ /dev/null
@@ -1 +0,0 @@
-../colibri-imx7/gpio-tool \ No newline at end of file
diff --git a/recipes-support/gpio-tool/files/colibri-imx7/gpio-tool b/recipes-support/gpio-tool/files/colibri-imx7/gpio-tool
deleted file mode 100755
index 318137f..0000000
--- a/recipes-support/gpio-tool/files/colibri-imx7/gpio-tool
+++ /dev/null
Binary files differ
diff --git a/recipes-support/gpio-tool/files/gpio-tool b/recipes-support/gpio-tool/files/gpio-tool
deleted file mode 100755
index 85a2fe8..0000000
--- a/recipes-support/gpio-tool/files/gpio-tool
+++ /dev/null
Binary files differ
diff --git a/recipes-support/gpio-tool/files/gpio-tool.desktop b/recipes-support/gpio-tool/files/gpio-tool.desktop
deleted file mode 100644
index a862332..0000000
--- a/recipes-support/gpio-tool/files/gpio-tool.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/env xdg-open
-
-[Desktop Entry]
-Version=1.0
-Type=Application
-Terminal=false
-Icon[C]=gpio-tool.png
-Exec=/usr/bin/gpio-tool
-Name[C]=GPIO Tool
-Name=GPIO Tool
-Icon=gpio-tool.png
diff --git a/recipes-support/gpio-tool/files/gpio-tool.png b/recipes-support/gpio-tool/files/gpio-tool.png
deleted file mode 100644
index 2227e81..0000000
--- a/recipes-support/gpio-tool/files/gpio-tool.png
+++ /dev/null
Binary files differ
diff --git a/recipes-support/gpio-tool/gpio-tool.bb b/recipes-support/gpio-tool/gpio-tool.bb
deleted file mode 100644
index 52d2477..0000000
--- a/recipes-support/gpio-tool/gpio-tool.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SUMMARY = "GPIOConfig tool for Toradex Modules"
-SECTION = "base"
-LICENSE = "CLOSED"
-PR = "r3"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS = "glib-2.0 gtk+"
-
-SRC_URI = " \
- file://gpio-tool \
- file://gpio-tool.desktop \
- file://gpio-tool.png \
-"
-
-inherit bin_package
-
-#no gnu_hash in binaries, skip QA dev-so for this package
-#we have symlinks ending in .so, skip QA ldflags for this package
-#inhibit warnings about files being stripped
-INSANE_SKIP:${PN} = "ldflags already-stripped"
-
-do_install() {
- install -d ${D}/${bindir}
- install -d ${D}/${datadir}/applications
- install -d ${D}/${datadir}/pixmaps
- install -d ${D}${ROOT_HOME}/Desktop
- install -m 755 ${WORKDIR}/gpio-tool ${D}/${bindir}/
- install -m 644 ${WORKDIR}/gpio-tool.desktop ${D}/${datadir}/applications/
- install -m 644 ${WORKDIR}/gpio-tool.png ${D}/${datadir}/pixmaps/
- ln -s ${datadir}/applications/gpio-tool.desktop ${D}${ROOT_HOME}/Desktop/
-}