summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland/weston-init.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 11:30:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 17:32:46 +0200
commit48fb6ae80a1aa5765ff420877219d8eb35b11396 (patch)
tree0e422642fa0d25006184f51dd9fc4b9f0b0c92b2 /recipes-graphics/wayland/weston-init.bbappend
parent9f699aed67850db573ee3c51de7110fd235084c1 (diff)
recipes: cope with moved directory for unpackHEADmaster
OE master (styhead) no longer unpacks in ${WORKDIR} but rather does it in path defined by the new variable UNPACKDIR. Additionally '${S} = ${WORKDIR}' is no longer allowed and results in a parse time error. Cope with the change so that the layer builds against scarthgap and styhead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/wayland/weston-init.bbappend')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 223eb2c..db05a96 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
SRC_URI += "file://toradex-save-touchscreen-calibration.sh"
+OURFILEPATH = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
PACKAGECONFIG[touchscreen-calibration] = ",,"
PACKAGECONFIG:append:tdx = " touchscreen-calibration"
@@ -18,6 +20,6 @@ do_install:append:tdx() {
sed -i -e "/enable_tap=/d" ${D}${sysconfdir}/xdg/weston/weston.ini
sed -i -e "/^\[libinput\]/a enable_tap=true" ${D}${sysconfdir}/xdg/weston/weston.ini
- install -Dm0755 ${WORKDIR}/toradex-save-touchscreen-calibration.sh ${D}${bindir}/toradex-save-touchscreen-calibration
+ install -Dm0755 ${OURFILEPATH}/toradex-save-touchscreen-calibration.sh ${D}${bindir}/toradex-save-touchscreen-calibration
fi
}