summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-08-01 15:23:55 +0200
committerMing Liu <ming.liu@toradex.com>2022-08-06 18:39:33 +0200
commitff29f4ef087da0d960ba7c778764e53c70f2e124 (patch)
tree3ac114a065bf63b0c6b55e6ee8e8b4005b6b5642 /recipes-devtools
parent8356eee884fa129269797fa47677e9ced741fd7c (diff)
meta: drop deprecated machine references
We dont support the following machines any more: colibri-t20/colibri-t30/apalis-t30/apalis-tk1/colibri-vf, let's drop their references. The recipe spidev-test is only used by colibri-vf, also drop it. Related-to: ELB-4471 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/spidev-test/spidev-test.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-devtools/spidev-test/spidev-test.bb b/recipes-devtools/spidev-test/spidev-test.bb
deleted file mode 100644
index 2c403e6..0000000
--- a/recipes-devtools/spidev-test/spidev-test.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-COMPATIBLE_MACHINE = "(colibri-vf)"
-
-SUMMARY = "The Linux kernels spidev-test programm"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-S = "${WORKDIR}"
-
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
-do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
-
-# the spidev_test.c example got moved to tools/spi/ starting with
-# the v.4.5.y kernel
-KERNELPATH = "tools/spi/spidev_test.c"
-KERNELPATH-OLD = "Documentation/spi/spidev_test.c"
-
-do_compile () {
- if [ -f "${STAGING_KERNEL_DIR}/${KERNELPATH}" ]
- then
- ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH} -o spidev_test
- else
- ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH-OLD} -o spidev_test
- fi
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 ${S}/spidev_test ${D}${bindir}/
-}