summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:16:35 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:16:35 +0200
commitfd9e78919a064a927a3dbc8de204d74fe8559066 (patch)
treed6b3aaee0a6d6fc181f6334a5937803cde7bfe0b /recipes-support
parent4ba4419239d8a235d80e8197bb73b055476f2d78 (diff)
layer: convert to new override syntax
This is the result of automated script (0.9.3) conversion: +# meta-toradex-distro +vars = vars + ["preempt-rt","tdx","upstream"] +# meta-toradex-* machines +vars = vars + ["apalis-","colibri-","verdin-","tegra124"] +# meta-freescale +vars = vars + ["imx","mx6","mx7","mx8","use-mainline-bsp","use-nxp-bsp"] ../openembedded-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libsoc/libsoc_0.8.2.bbappend32
-rw-r--r--recipes-support/libusbgx/libusbgx_git.bb8
-rw-r--r--recipes-support/snapd/snapd_2.25.bb12
3 files changed, 26 insertions, 26 deletions
diff --git a/recipes-support/libsoc/libsoc_0.8.2.bbappend b/recipes-support/libsoc/libsoc_0.8.2.bbappend
index 1a77694..f28b7ff 100644
--- a/recipes-support/libsoc/libsoc_0.8.2.bbappend
+++ b/recipes-support/libsoc/libsoc_0.8.2.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/libsoc:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/libsoc:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -8,23 +8,23 @@ SRC_URI += " \
file://0001-libsoc-use-sane-board-naming.patch \
"
-BOARD_apalis-imx6 = "apalis-imx6"
-BOARD_apalis-tk1 = "apalis-tk1"
-BOARD_colibri-imx6 = "colibri-imx6"
-BOARD_colibri-imx6ull = "colibri-imx6ull"
-BOARD_colibri-imx6ull-emmc = "colibri-imx6ull"
-BOARD_colibri-imx7 = "colibri-imx7"
-BOARD_colibri-imx7-emmc = "colibri-imx7-emmc"
+BOARD:apalis-imx6 = "apalis-imx6"
+BOARD:apalis-tk1 = "apalis-tk1"
+BOARD:colibri-imx6 = "colibri-imx6"
+BOARD:colibri-imx6ull = "colibri-imx6ull"
+BOARD:colibri-imx6ull-emmc = "colibri-imx6ull"
+BOARD:colibri-imx7 = "colibri-imx7"
+BOARD:colibri-imx7-emmc = "colibri-imx7-emmc"
-PACKAGECONFIG_apalis-imx6 = "allboardconfigs enableboardconfig python"
-PACKAGECONFIG_apalis-tk1 = "allboardconfigs enableboardconfig python"
-PACKAGECONFIG_colibri-imx6 = "allboardconfigs enableboardconfig python"
-PACKAGECONFIG_colibri-imx6ull = "allboardconfigs enableboardconfig python"
-PACKAGECONFIG_colibri-imx6ull-emmc = "allboardconfigs enableboardconfig python"
-PACKAGECONFIG_colibri-imx7 = "allboardconfigs enableboardconfig python"
-PACKAGECONFIG_colibri-imx7-emmc = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:apalis-imx6 = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:apalis-tk1 = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:colibri-imx6 = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:colibri-imx6ull = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:colibri-imx6ull-emmc = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:colibri-imx7 = "allboardconfigs enableboardconfig python"
+PACKAGECONFIG:colibri-imx7-emmc = "allboardconfigs enableboardconfig python"
-pkg_postinst_ontarget_${PN}_colibri-imx6ull () {
+pkg_postinst_ontarget:${PN}:colibri-imx6ull () {
IS_WIFI_DTB=`grep -c toradex,colibri_imx6ull-wifi /proc/device-tree/compatible`
if [ $IS_WIFI_DTB -gt 0 ]; then
mv -f ${datadir}/libsoc/colibri-imx6ull.conf ${datadir}/libsoc/colibri-imx6ull.conf.bak
diff --git a/recipes-support/libusbgx/libusbgx_git.bb b/recipes-support/libusbgx/libusbgx_git.bb
index 6449f9c..44b461b 100644
--- a/recipes-support/libusbgx/libusbgx_git.bb
+++ b/recipes-support/libusbgx/libusbgx_git.bb
@@ -22,11 +22,11 @@ SRC_URI = " \
S = "${WORKDIR}/git"
MACHINE_NAME ?= "${MACHINE}"
-do_compile_append () {
+do_compile:append () {
sed -e "s:@@PRODUCT_NAME@@:${MACHINE_NAME}:" ${WORKDIR}/g1.schema.in > ${WORKDIR}/g1.schema
}
-do_install_append () {
+do_install:append () {
if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/usbg.service ${D}${systemd_unitdir}/system
@@ -37,12 +37,12 @@ do_install_append () {
}
SYSTEMD_PACKAGES = "${PN}-examples"
-SYSTEMD_SERVICE_${PN}-examples = "usbg.service"
+SYSTEMD_SERVICE:${PN}-examples = "usbg.service"
PACKAGES =+ "${PN}-examples"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-FILES_${PN}-examples = " \
+FILES:${PN}-examples = " \
${bindir}/gadget-* \
${bindir}/show-gadgets \
${bindir}/show-udcs \
diff --git a/recipes-support/snapd/snapd_2.25.bb b/recipes-support/snapd/snapd_2.25.bb
index e1998e8..32060f0 100644
--- a/recipes-support/snapd/snapd_2.25.bb
+++ b/recipes-support/snapd/snapd_2.25.bb
@@ -21,7 +21,7 @@ DEPENDS = " \
xfsprogs \
"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
ca-certificates \
kernel-module-squashfs \
squashfs-tools \
@@ -43,13 +43,13 @@ inherit systemd go autotools pkgconfig python3native
# and we need to tell the autotools class to look in there.
AUTOTOOLS_SCRIPT_PATH = "${S}/cmd"
-SYSTEMD_SERVICE_${PN} = "snapd.service"
+SYSTEMD_SERVICE:${PN} = "snapd.service"
-do_configure_prepend() {
+do_configure:prepend() {
(cd ${S} ; ./mkversion.sh ${PV})
}
-do_configure_append() {
+do_configure:append() {
go_do_configure
}
@@ -87,7 +87,7 @@ do_install() {
echo "PATH=\$PATH:/snap/bin" > ${D}${sysconfdir}/profile.d/20-snap.sh
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${systemd_unitdir}/system/ \
/var/lib/snapd \
/var/snap \
@@ -96,4 +96,4 @@ FILES_${PN} += " \
# ERROR: snapd-2.23.5-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary:
# '.../snapd/usr/lib/snapd/snap-exec' [ldflags]
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"