summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-06-19 14:04:11 +0300
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-30 10:51:34 +0200
commit758eb5c09107bdcbb3362b636cdf418e471d18fa (patch)
tree7b02425d29668fdc964bb8e4b0d34a65e77f0d24 /recipes-kernel
parent162e98add824495c463bb0d1c28849199b269264 (diff)
linux-toradex-mainline: fix adding symbols to dtb files
There is a dead code in the linux-toradex-mainline.inc, that doesn't really install dtb files into the final image. Remove this code add add the option to compile dtb files with symbols in the proper place. Related-to: ELB-2797 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com> (cherry picked from commit e0beff9f048259b24b147b21f49c1463ebd70511)
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline.inc6
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_%.bbappend1
2 files changed, 1 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline.inc b/recipes-kernel/linux/linux-toradex-mainline.inc
index 37bc7f3..ceea4f5 100644
--- a/recipes-kernel/linux/linux-toradex-mainline.inc
+++ b/recipes-kernel/linux/linux-toradex-mainline.inc
@@ -23,12 +23,6 @@ kernel_do_configure_append_preempt-rt() {
oe_runmake olddefconfig
}
-do_install_append() {
- install -d ${D}/boot
- make -C ${S} O=${B} ARCH=$ARCH DTC_FLAGS="-@" dtbs || true
- install -m 0644 "${B}/arch/$ARCH/boot/dts/*.dtb" ${D}/boot || true
-}
-
# Additional file deployed by recent mainline kernels
FILES_${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
diff --git a/recipes-kernel/linux/linux-toradex-mainline_%.bbappend b/recipes-kernel/linux/linux-toradex-mainline_%.bbappend
new file mode 100644
index 0000000..a4bc867
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline_%.bbappend
@@ -0,0 +1 @@
+EXTRA_OEMAKE += "DTC_FLAGS=-@ "