summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-10-09 12:11:27 -0300
committerMax Krummenacher <max.krummenacher@toradex.com>2023-10-10 12:36:09 -0300
commit93e392f8e6cd94a5dbea07525c189d4655bc7a21 (patch)
treec2996b86eee15bb392f8533cd9331db65e755155 /recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
parent86fd9c3d8c8058f8043240bcfc78b1452633db14 (diff)
linux-toradex-mainline: split out common code into a inc file
This makes the non-rt and rt recipe more independent and prepares for further refactoring. Related-to: ELB-5359 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel/linux/linux-toradex-mainline-rt_git.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt_git.bb21
1 files changed, 14 insertions, 7 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
index 09df83e..df41c28 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
@@ -1,17 +1,24 @@
-LINUX_VERSION ?= "6.5-rc"
-require recipes-kernel/linux/linux-toradex-mainline_git.bb
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-git:"
+require linux-toradex-mainline-common.inc
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-toradex-mainline-rt-git:"
SUMMARY = "Toradex mainline real-time Linux kernel"
# To build the RT kernel we use the RT kernel git repo rather than applying
# the RT patch on top of a vanilla kernel.
LINUX_REPO = "git://git.kernel.org/pub/scm/linux/kernel/git/rt/linux-rt-devel.git"
-KBRANCH = "linux-6.5.y-rt"
-SRCREV_machine = "16ae0de52ef9f7e5c2cd7e8443f5195c176353ea"
-SRCREV_machine:use-head-next = "${AUTOREV}"
-
+TDX_PATCHES = " \
+ file://0001-thermal-imx-Update-critical-temp-threshold.patch \
+ file://0002-Revert-drm-panel-simple-drop-use-of-data-mapping-pro.patch \
+ file://0003-drivers-chipidea-disable-runtime-pm-for-imx6ul.patch \
+ file://0004-media-i2c-ov5640-Implement-get_mbus_config.patch \
+"
SRC_URI:append = " \
file://preempt-rt.scc \
file://preempt-rt-less-latency.scc \
"
+
+LINUX_VERSION ?= "6.5-rc"
+KBRANCH = "linux-6.5.y-rt"
+SRCREV_machine = "16ae0de52ef9f7e5c2cd7e8443f5195c176353ea"
+SRCREV_machine:use-head-next = "${AUTOREV}"