summaryrefslogtreecommitdiff
path: root/recipes-core/udev/udev-toradex-rules.bb
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-07-26 15:58:39 +0200
committerFrancesco Dolcini <francesco.dolcini@toradex.com>2022-07-26 14:49:30 +0000
commita403bdf1785b7975411acc7c3a920bd52cfee5f2 (patch)
tree92b5caa9bfa35895f6be84679bf33617a7d3e9c2 /recipes-core/udev/udev-toradex-rules.bb
parent24da367be6a1d33d9ce2947658b12fc8e4444d33 (diff)
udev-toradex-rules: introduce bootpart-automount.rules
It will handle bind mount boot partition to /boot. provided that the modules boot from eMMC/SDCard devices and there is a boot partition present. It whould work with both sysvinit and systemd init managers. Related-to: ELB-4620 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-core/udev/udev-toradex-rules.bb')
-rw-r--r--recipes-core/udev/udev-toradex-rules.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/recipes-core/udev/udev-toradex-rules.bb b/recipes-core/udev/udev-toradex-rules.bb
index a94da96..c31f416 100644
--- a/recipes-core/udev/udev-toradex-rules.bb
+++ b/recipes-core/udev/udev-toradex-rules.bb
@@ -3,16 +3,23 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRC_URI = "\
- file://99-toradex.rules \
file://10-toradex-wifi-ifnames.link \
+ file://99-toradex.rules \
+ file://bootpart-automount.rules \
file://toradex-adc.sh \
+ file://toradex-mount-bootpart.sh \
"
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d
install -d ${D}${sysconfdir}/udev/scripts
install -d ${D}${sysconfdir}/systemd/network
+ install -m 0644 ${WORKDIR}/10-toradex-wifi-ifnames.link ${D}${sysconfdir}/systemd/network/
install -m 0644 ${WORKDIR}/99-toradex.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${WORKDIR}/bootpart-automount.rules ${D}${sysconfdir}/udev/rules.d/
install -m 0755 ${WORKDIR}/toradex-adc.sh ${D}${sysconfdir}/udev/scripts/
- install -m 0644 ${WORKDIR}/10-toradex-wifi-ifnames.link ${D}${sysconfdir}/systemd/network/
+ install -m 0755 ${WORKDIR}/toradex-mount-bootpart.sh ${D}${sysconfdir}/udev/scripts/
+
+ sed -i 's|@systemd_unitdir@|${systemd_unitdir}|g' ${D}${sysconfdir}/udev/scripts/toradex-mount-bootpart.sh
+ sed -i 's|@base_sbindir@|${base_sbindir}|g' ${D}${sysconfdir}/udev/scripts/toradex-mount-bootpart.sh
}