summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/libubootenv_%.bbappend
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-07-21 12:46:46 +0200
committerMing Liu <ming.liu@toradex.com>2022-07-26 15:26:30 +0200
commita01555a69039fa02665d4089e9c80236d872752e (patch)
tree7ceaad76e18da7b3bcbd2bff601f91cac545a9be /recipes-bsp/u-boot/libubootenv_%.bbappend
parent15a035b9d11fe8561b037ffecfee3f4a7c403b36 (diff)
libubootenv: move in fw_env.config
Currently we have downstream/upstream Toradex uboot recipes and we dont want to add fw_env.config for both of them to avoid code redundant. Let's add fw_env.config to libubootenv, which will be installed for both donwstream/upstream distros. Change libubootenv to a machine arch recipe since now it has machine specific fw_env.config files. Related-to: ELB-4536 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/libubootenv_%.bbappend')
-rw-r--r--recipes-bsp/u-boot/libubootenv_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/libubootenv_%.bbappend b/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 0000000..3f8a71b
--- /dev/null
+++ b/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI:append = " file://fw_env.config"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RRECOMMENDS:${PN} += "u-boot-default-env"
+
+do_install:append() {
+ install -d ${D}/${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}/${sysconfdir}/
+}