summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiago De Franco <hiago.franco@toradex.com>2023-08-30 10:54:08 -0300
committerMax Krummenacher <max.krummenacher@toradex.com>2023-09-21 08:08:21 -0300
commitc907c047234f3691fc285f937aed3f4f8bb4af98 (patch)
tree63a22442ca3efe7c6f2eabaedee50c3e46c318d4
parent2dd803c42682cdc51cd153c5b9102df4e25af1ae (diff)
u-boot-toradex: do not deploy u-boot-with-spl.imx binary
Stop deploying u-boot-with-spl.imx, this is not required to properly flash the board nor for debugging. Separated SPL and U-Boot proper binaries available, used by Tezi and can be easily flashed using update_uboot and update_spl helper scripts. This enables some simplification on Tezi. Signed-off-by: Hiago De Franco <hiago.franco@toradex.com> (cherry picked from commit 81a446adde4296c7e68f916bc536414a1caa1397)
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.07.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
index 44f70da..ffbd838 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
@@ -56,28 +56,6 @@ nand_padding () {
dd bs=1024 count=1 if=/dev/zero | cat - ${PADDING_DIR}/u-boot.imx.zero-padded > ${PADDING_DIR}/u-boot-nand.imx
}
-deploy_uboot_with_spl () {
- #Deploy u-boot-with-spl.imx
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx-${MACHINE}-${type}
- ln -sf u-boot-with-spl.imx-${MACHINE}-${type} ${DEPLOYDIR}/u-boot-with-spl.imx
- fi
- done
- unset j
- done
- unset i
- else
- install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx
- fi
-}
-
# build imx-boot from within U-Boot
inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
@@ -89,14 +67,6 @@ do_compile:append:colibri-imx7 () {
nand_padding
}
-do_deploy:append:colibri-imx6 () {
- deploy_uboot_with_spl
-}
-
-do_deploy:append:apalis-imx6 () {
- deploy_uboot_with_spl
-}
-
BOOT_TOOLS = "imx-boot-tools"
do_deploy:append:mx8m-generic-bsp() {
# Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary