summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2023-10-16 18:32:38 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-11-29 17:06:09 +0100
commit8b8d7107919e6b06a112ca4fba681d28386547bb (patch)
treecd02cf30b4c0b41679dae348ea2a169ab880f96c
parent1df7b3b60ce9c6a3ce8bb4beb5887913f5f8713d (diff)
btnxpuart: bluetooth nxp uart module configuration
As the power-down pin (PD#) is shared and handled by +mmc-pwrseq for mwifiex_sdio, make sure mwifiex gets loaded first. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> (cherry picked from commit db93e09dcc520be7efbe38c8c6717f77c289825e)
-rw-r--r--recipes-bsp/btnxpuartconf/btnxpuartconf/btnxpuart.conf1
-rw-r--r--recipes-bsp/btnxpuartconf/btnxpuartconf_1.0.bb14
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/btnxpuartconf/btnxpuartconf/btnxpuart.conf b/recipes-bsp/btnxpuartconf/btnxpuartconf/btnxpuart.conf
new file mode 100644
index 0000000..41ff853
--- /dev/null
+++ b/recipes-bsp/btnxpuartconf/btnxpuartconf/btnxpuart.conf
@@ -0,0 +1 @@
+install btnxpuart /sbin/modprobe mwifiex_sdio; sleep 1; /sbin/modprobe --ignore-install btnxpuart
diff --git a/recipes-bsp/btnxpuartconf/btnxpuartconf_1.0.bb b/recipes-bsp/btnxpuartconf/btnxpuartconf_1.0.bb
new file mode 100644
index 0000000..c5f9adf
--- /dev/null
+++ b/recipes-bsp/btnxpuartconf/btnxpuartconf_1.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Bluetooth NXP UART (btnxpuart) Configuration"
+
+DESCRIPTION = "As the power-down pin (PD#) is shared and handled by \
+mmc-pwrseq for mwifiex_sdio, make sure mwifiex gets loaded first."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://btnxpuart.conf"
+
+do_install () {
+ install -d ${D}/etc/modprobe.d/
+ install -m 0755 ${WORKDIR}/btnxpuart.conf ${D}/etc/modprobe.d/btnxpuart.conf
+}