summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-08-17 14:52:12 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-09-05 05:52:34 -0300
commit2ba95577264350546f17c655b6dd47f1e9bdae45 (patch)
tree91f8201c4c44124c36ee251e4e0f6be2aa2df332
parentc75248ef5754f6a0f4174f3578add449dfe01fd0 (diff)
u-boot-toradex: simplify use with imx-boot-container.bbclass
The class now handles to provide an imx-boot symlink to flash.bin. Also drop redundant entries in DEPENDS which are now part of the generic u-boot include file. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.07.bb24
1 files changed, 1 insertions, 23 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
index 65fff97..ee66a11 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
@@ -2,7 +2,7 @@ require recipes-bsp/u-boot/u-boot-common.inc
require recipes-bsp/u-boot/u-boot.inc
LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
-DEPENDS += "bc-native dtc-native python3-setuptools-native"
+DEPENDS += "bc-native dtc-native"
# hash of release v2022.07"
PV = "2022.07"
@@ -80,7 +80,6 @@ deploy_uboot_with_spl () {
# build imx-boot from within U-Boot
inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
-DEPENDS:imx-boot-container += "bc-native bison-native dtc-native python3-setuptools-native swig-native"
do_compile:append:colibri-imx6ull () {
nand_padding
@@ -119,24 +118,3 @@ do_deploy:append:mx8m-generic-bsp() {
unset i
fi
}
-
-do_deploy:append:imx-boot-container() {
- # Deploy imx-boot
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- install -d ${DEPLOYDIR}
- install -m 0644 ${B}/${config}/flash.bin ${DEPLOYDIR}/imx-boot-${MACHINE}-${type}
- ln -sf imx-boot-${MACHINE}-${type} ${DEPLOYDIR}/imx-boot
- fi
- done
- unset j
- done
- unset i
- fi
-}