summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-10-10 14:23:24 -0300
committerMax Krummenacher <max.krummenacher@toradex.com>2023-10-16 12:10:42 -0300
commit0e97daf8eb2f622bac4141a9a657693ef2aa321f (patch)
tree3d0dc3029eaca0e2712011050e488956179480e2
parentfcf94a55931041ac828e289470b1313c113f827f (diff)
u-boot-toradex: upstream: ti: fix dependencies
Follow meta-ti downstream dependency change on ti-sci-fw and change to do the atf, dm, optee dependency through packageconfig. See also commits: 22b8a0a3 ("recipes-bsp:ti-sci-fw: Add k3r5 as COMPATIBLE_MACHINE") 69056610 ("recipes-bsp: u-boot-ti.inc: Remove ti-sci-fw from DEPENDS for k3 machine") ti-sci-fw is only needed for the k3r5 build, removing it from k3 fixes: | ERROR: Nothing PROVIDES 'ti-sci-fw' (but .../meta-toradex-bsp-common/recipes-bsp/u-boot/u-boot-toradex_mainline.bb DEPENDS on or otherwise requires it) | ti-sci-fw was skipped: incompatible with machine verdin-am62 (not in COMPATIBLE_MACHINE) ti-dm-fw is only needed for the k3 build, removing it fixes errors during recipe parse, e.g.: | ERROR: Nothing RPROVIDES 'ldconfig' (but mc:k3r5:.../openembedded-core/meta/recipes-devtools/dpkg/dpkg_1.22.0.bb RDEPENDS on or otherwise requires it) Related-to: ELB-5428 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti.inc35
1 files changed, 29 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti.inc b/recipes-bsp/u-boot/u-boot-toradex-ti.inc
index 1d9b110..b8e9a39 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti.inc
@@ -1,11 +1,34 @@
# SYSFW/TIFS Firmware
-DEPENDS:append:k3 = " python3-jsonschema-native python3-pyelftools-native python3-pyyaml-native optee-os ti-sci-fw ti-dm-fw trusted-firmware-a"
-DEPENDS:append:k3r5 = " python3-jsonschema-native python3-pyelftools-native python3-pyyaml-native ti-sci-fw ti-dm-fw"
-BL31 = "${STAGING_DIR_HOST}/firmware/bl31.bin"
-TEE = "${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/bl32.bin"
+DEPENDS:append:k3 = " python3-jsonschema-native python3-pyelftools-native python3-pyyaml-native"
+DEPENDS:append:k3r5 = " python3-jsonschema-native python3-pyelftools-native python3-pyyaml-native ti-sci-fw"
+
+DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f"
+
+PLAT_SFX = ""
+PLAT_SFX:j721e = "j721e"
+PLAT_SFX:j7200 = "j7200"
+PLAT_SFX:j721s2 = "j721s2"
+PLAT_SFX:j784s4 = "j784s4"
+PLAT_SFX:am65xx = "am65xx"
+PLAT_SFX:am64xx = "am64xx"
+PLAT_SFX:am62xx = "am62xx"
+PLAT_SFX:am62axx = "am62axx"
+
+PACKAGECONFIG[atf] = "BL31=${STAGING_DIR_HOST}/firmware/bl31.bin,,trusted-firmware-a"
+PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/bl32.bin,,optee-os"
+PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/ti-dm/${PLAT_SFX}/${DM_FIRMWARE},,ti-dm-fw"
+
+PACKAGECONFIG:append:aarch64 = " atf optee"
+PACKAGECONFIG:append:j721e = " dm"
+PACKAGECONFIG:append:j7200 = " dm"
+PACKAGECONFIG:append:j721s2 = " dm"
+PACKAGECONFIG:append:j784s4 = " dm"
+PACKAGECONFIG:append:am62xx = " dm"
+PACKAGECONFIG:append:am62axx = " dm"
+
BINMAN_INDIRS = "${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware"
-EXTRA_OEMAKE:append:k3 = " BL31=${BL31} TEE=${TEE} BINMAN_INDIRS=${BINMAN_INDIRS}"
-EXTRA_OEMAKE:append:k3r5 = " BINMAN_INDIRS=${BINMAN_INDIRS}"
+
+EXTRA_OEMAKE:append = " ${PACKAGECONFIG_CONFARGS} BINMAN_INDIRS=${BINMAN_INDIRS}"
do_deploy:append:k3r5 () {
if [ -n "${UBOOT_CONFIG}" ]