summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxdm/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/lxdm/files')
-rw-r--r--recipes-lxde/lxdm/files/init41
-rw-r--r--recipes-lxde/lxdm/files/lxdm-configure-ac.patch11
-rw-r--r--recipes-lxde/lxdm/files/xinitrc51
3 files changed, 0 insertions, 103 deletions
diff --git a/recipes-lxde/lxdm/files/init b/recipes-lxde/lxdm/files/init
deleted file mode 100644
index d8bb4eb..0000000
--- a/recipes-lxde/lxdm/files/init
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-
-. /etc/init.d/functions
-
-DAEMON=/usr/sbin/lxdm
-PIDDIR=/var/run
-PIDFILE=$PIDDIR/lxdm.pid
-
-for x in $(cat /proc/cmdline); do
- case $x in
- x11=false)
- echo "LXDM disabled"
- exit 0;
- ;;
- esac
-done
-
-case "$1" in
- start)
- echo "Starting LXDM"
- start-stop-daemon --start --quiet --pidfile $PIDFILE -m -b \
- --exec $DAEMON
- ;;
-
- stop)
- echo "Stopping LXDM"
- start-stop-daemon --stop --quiet --pidfile $PIDFILE
- ;;
-
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
-
- *)
- echo "usage: $0 { start | stop | restart }"
- ;;
-esac
-
-exit 0
diff --git a/recipes-lxde/lxdm/files/lxdm-configure-ac.patch b/recipes-lxde/lxdm/files/lxdm-configure-ac.patch
deleted file mode 100644
index c9197b9..0000000
--- a/recipes-lxde/lxdm/files/lxdm-configure-ac.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lxdm-0.4.1/configure.ac~ 2014-04-30 17:20:10.000000000 +0200
-+++ lxdm-0.4.1/configure.ac 2014-04-30 17:58:10.553136640 +0200
-@@ -3,7 +3,7 @@
-
- AC_PREREQ([2.63])
- AC_INIT([lxdm], [0.4.1], [http://lxde.org/])
--AM_INIT_AUTOMAKE([-Wall -Werror foreign])
-+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
-
- AC_CONFIG_SRCDIR([src/lxdm.c])
- AC_CONFIG_HEADERS([config.h])
diff --git a/recipes-lxde/lxdm/files/xinitrc b/recipes-lxde/lxdm/files/xinitrc
deleted file mode 100644
index 68121fb..0000000
--- a/recipes-lxde/lxdm/files/xinitrc
+++ /dev/null
@@ -1,51 +0,0 @@
-# Script based on Gentoo lxdm xinitrc
-
-case $SHELL in
- */bash)
- [ -z "$BASH" ] && exec $SHELL $0 "$@"
- set +o posix
- [ -f /etc/profile ] && . /etc/profile
- if [ -f $HOME/.bash_profile ]; then
- . $HOME/.bash_profile
- elif [ -f $HOME/.bash_login ]; then
- . $HOME/.bash_login
- elif [ -f $HOME/.profile ]; then
- . $HOME/.profile
- fi
- ;;
- */zsh)
- [ -z "$ZSH_NAME" ] && exec $SHELL $0 "$@"
- emulate -R zsh
- [ -d /etc/zsh ] && zdir=/etc/zsh || zdir=/etc
- zhome=${ZDOTDIR:-$HOME}
- # zshenv is always sourced automatically.
- [ -f $zdir/zprofile ] && . $zdir/zprofile
- [ -f $zhome/.zprofile ] && . $zhome/.zprofile
- [ -f $zdir/zlogin ] && . $zdir/zlogin
- [ -f $zhome/.zlogin ] && . $zhome/.zlogin
- ;;
- */csh|*/tcsh)
- # [t]cshrc is always sourced automatically.
- # Note that sourcing csh.login after .cshrc is non-standard.
- xsess_tmp=`mktemp /tmp/xsess-env-XXXXXX`
- $SHELL -c "if (-f /etc/csh.login) source /etc/csh.login; if (-f ~/.login) source ~/.login; /bin/sh -c export -p >! $xsess_tmp"
- . $xsess_tmp
- rm -f $xsess_tmp
- ;;
- *) # Plain sh, ksh, and anything we do not know.
- [ -f /etc/profile ] && . /etc/profile
- [ -f $HOME/.profile ] && . $HOME/.profile
- ;;
-esac
-
-[ -f /etc/xprofile ] && . /etc/xprofile
-[ -f $HOME/.xprofile ] && . $HOME/.xprofile
-
-# run all system xinitrc shell scripts.
-XINITDIR=/etc/X11/Xinit.d
-XINITFILES=`ls -X $XINITDIR`
-for XINITFILE in $XINITFILES; do
- if [ -x "$XINITDIR/$XINITFILE" ]; then
- . $XINITDIR/$XINITFILE
- fi
-done