summaryrefslogtreecommitdiff
path: root/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-06-08 20:46:03 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2018-11-17 14:59:47 +0100
commit46d1a0175c28aed234e628c325655d0ce787d4cc (patch)
treeb73bb8874d4466a810dafb293bf5f186d2845fe2 /recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
parenteef7735e187473ec5338c853bbb0b3fae7df4795 (diff)
wireless-tools: re-add from openembedded-core
wireless-tools got removed from openembedded-core but the package libiw from the recipe is required for lxde panel. Re-add it here. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch')
-rw-r--r--recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch b/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
new file mode 100644
index 0000000..3a22c3f
--- /dev/null
+++ b/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
@@ -0,0 +1,19 @@
+When /etc/ld.so.cache is writeable by user running bitbake then it creates invalid cache
+(in my case libstdc++.so cannot be found after building zlib(-native) and I have to call
+touch */libstdc++.so && /sbin/ldconfig to fix it.
+
+So remove ldconfig call from make install-libs
+
+Upstream-Status: Inappropriate [disable feature]
+
+diff -uNr wireless_tools.29.orig/Makefile wireless_tools.29/Makefile
+--- wireless_tools.29.orig/Makefile 2007-09-18 01:56:46.000000000 +0200
++++ wireless_tools.29/Makefile 2012-02-15 20:46:41.780763514 +0100
+@@ -163,7 +163,6 @@
+ install -m 755 $(DYNAMIC) $(INSTALL_LIB)
+ ln -sfn $(DYNAMIC) $(INSTALL_LIB)/$(DYNAMIC_LINK)
+ @echo "*** Don't forget to add $(INSTALL_LIB) to /etc/ld.so.conf, and run ldconfig as root. ***"
+- @$(LDCONFIG) || echo "*** Could not run ldconfig ! ***"
+
+ # Install the static library
+ install-static:: $(STATIC)