summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/image_type_tezi.bbclass21
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/99-toradex.rules21
-rw-r--r--recipes-kernel/linux/device-tree-overlays-mainline_git.bb2
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt_git.bb4
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb4
9 files changed, 71 insertions, 5 deletions
diff --git a/classes/image_type_tezi.bbclass b/classes/image_type_tezi.bbclass
index 1eacbf8..fd53b3e 100644
--- a/classes/image_type_tezi.bbclass
+++ b/classes/image_type_tezi.bbclass
@@ -33,6 +33,13 @@ TEZI_ROOT_SUFFIX ??= "tar.xz"
TEZI_ROOT_PART_TYPE ??= "83"
TEZI_ROOT_PART_SIZE ??= "512"
TEZI_ROOT_FILELIST ??= ""
+TEZI_DATA_ENABLED ??= "0"
+TEZI_DATA_PART_SIZE ??= "512"
+TEZI_DATA_PART_TYPE ??= "83"
+TEZI_DATA_LABEL ??= "DATA"
+TEZI_DATA_FSTYPE ??= "ext4"
+TEZI_DATA_FSOPTS ?= "-E nodiscard"
+TEZI_DATA_FILES ?= ""
TEZI_USE_BOOTFILES ??= "true"
TEZI_AUTO_INSTALL ??= "false"
TEZI_BOOT_SUFFIX ??= "${@'bootfs.tar.xz' if oe.types.boolean('${TEZI_USE_BOOTFILES}') else ''}"
@@ -275,6 +282,20 @@ def rootfs_tezi_emmc(d, use_bootfiles):
filesystem_partitions.append(rootfs)
+ if d.getVar('TEZI_DATA_ENABLED') == "1":
+ data = {
+ "partition_size_nominal": d.getVar('TEZI_DATA_PART_SIZE'),
+ "partition_type": d.getVar('TEZI_DATA_PART_TYPE'),
+ "want_maximised": True,
+ "content": {
+ "label": d.getVar('TEZI_DATA_LABEL'),
+ "filesystem_type": d.getVar('TEZI_DATA_FSTYPE'),
+ "mkfs_options": d.getVar('TEZI_DATA_FSOPTS'),
+ "filename": d.getVar('TEZI_DATA_FILES')
+ }
+ }
+ filesystem_partitions.append(data)
+
return [
OrderedDict({
"name": emmcdev,
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link
new file mode 100644
index 0000000..7058581
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-40528000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can2
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link
new file mode 100644
index 0000000..284ba25
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-40568000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can4
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link
new file mode 100644
index 0000000..03d124f
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-27a1000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can1
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link
new file mode 100644
index 0000000..12502d7
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-27d1000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can3
diff --git a/recipes-core/udev/files/aquila-am69/99-toradex.rules b/recipes-core/udev/files/aquila-am69/99-toradex.rules
new file mode 100644
index 0000000..a40a5a2
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/99-toradex.rules
@@ -0,0 +1,21 @@
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="40b00000.i2c", SYMLINK+="aquila-i2c1"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="40b10000.i2c", SYMLINK+="aquila-i2c2"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2000000.i2c", SYMLINK+="aquila-i2c3"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2010000.i2c", SYMLINK+="aquila-i2c4"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2020000.i2c", SYMLINK+="aquila-i2c5"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2050000.i2c", SYMLINK+="aquila-i2c6"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="42120000.i2c", SYMLINK+="aquila-i2c-on-module"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="2810000.serial", SYMLINK+="aquila-uart1"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="42300000.serial", SYMLINK+="aquila-uart2"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="2880000.serial", SYMLINK+="aquila-uart3"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="2800000.serial", SYMLINK+="aquila-uart4"
+ACTION=="add|change", KERNELS=="watchdog", SYMLINK+="aquila-watchdog", SYMLINK+="aquila-watchdog-soc"
+ACTION=="add|change", SUBSYSTEM=="spidev", KERNELS=="2120000.*spi", SYMLINK+="aquila-spi1-cs%n"
+ACTION=="add|change", SUBSYSTEM=="spidev", KERNELS=="2100000.*spi", SYMLINK+="aquila-spi2-cs%n"
+KERNEL=="mmcblk[0-9]", ENV{DEVTYPE}=="disk", KERNELS=="4f80000.mmc", SYMLINK+="emmc"
+KERNEL=="mmcblk[0-9]boot[0-9]", ENV{DEVTYPE}=="disk", KERNELS=="4f80000.mmc", SYMLINK+="emmc-boot%n"
+KERNEL=="mmcblk[0-9]p[0-9]", ENV{DEVTYPE}=="partition", KERNELS=="4f80000.mmc", SYMLINK+="emmc-part%n"
+#TODO ADC
+#SUBSYSTEM=="iio", KERNELS=="iio:device0", RUN+="/etc/udev/scripts/toradex-adc.sh"
+ACTION=="add|change", KERNEL=="mmcblk[0-9]", KERNELS=="4fb0000.mmc", SYMLINK+="aquila-sd"
+ACTION=="add|change", KERNEL=="mmcblk[0-9]p[0-9]*", KERNELS=="4fb0000.mmc", SYMLINK+="aquila-sd-part%n"
diff --git a/recipes-kernel/linux/device-tree-overlays-mainline_git.bb b/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
index 827b39b..f067c46 100644
--- a/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
+++ b/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
@@ -1,7 +1,7 @@
inherit toradex-devicetree
SRCBRANCH = "master"
-SRCREV = "7f35a26c74084d29244a032bce9a420b1564c116"
+SRCREV = "6e4765109a648b641da2916e415eeedcd58ca36b"
SRCREV:use-head-next = "${AUTOREV}"
COMPATIBLE_MACHINE = ".*(mx[678]).*"
diff --git a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
index 1c89edd..7360fb6 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
@@ -1,4 +1,4 @@
-LINUX_VERSION ?= "6.1.83-rt28"
+LINUX_VERSION ?= "6.1.92-rt32"
require recipes-kernel/linux/linux-toradex-mainline_git.bb
SUMMARY = "Toradex mainline real-time Linux kernel"
@@ -7,7 +7,7 @@ SUMMARY = "Toradex mainline real-time Linux kernel"
LINUX_REPO = "git://git.kernel.org/pub/scm/linux/kernel/git/rt/linux-stable-rt.git"
KBRANCH = "v6.1-rt"
-SRCREV_machine = "c88639fef1f2a6e8da6d4c5b6a9b07a3bd0a6cc7"
+SRCREV_machine = "b5e9492f0754bee991234b10ace058b275a2d8b4"
SRCREV_machine:use-head-next = "${AUTOREV}"
SRC_URI:append = " \
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index a58cc27..b39b20c 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -55,10 +55,10 @@ SRC_URI:append = " \
file://0002-arm-dts-nxp-imx-Add-support-for-Apalis-Evaluation-Bo.patch \
"
-LINUX_VERSION ?= "6.1.89"
+LINUX_VERSION ?= "6.1.92"
KBRANCH = "linux-6.1.y"
KERNEL_VERSION_SANITY_SKIP = "1"
-SRCREV_machine = "dcbc050cb0d304c3427d6583384eebcaf0e3caee"
+SRCREV_machine = "88690811da69826fdb59d908a6e5e9d0c63b581a"
SRCREV_machine:use-head-next = "${AUTOREV}"
S = "${WORKDIR}/git"