summaryrefslogtreecommitdiff
path: root/recipes-devtools/mmc/mmc-utils_chromiumos.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-02-12 09:06:27 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-02-12 09:06:27 +0100
commit5a2b99e240f4b87707db720e3c61a199f8537ec6 (patch)
treed6d4576a4fa59d6eaa3f1b59225cfe58622fff5d /recipes-devtools/mmc/mmc-utils_chromiumos.bb
parent66bd4c58c9b29c3e6ec1028755c3088908819a65 (diff)
mmc-utils: add recipe for chromiumos version thereof
Add a recipe for the Chromium OS version of the mmc-utils able to handle Extended CSD revision 1.7 of the latest MMC 5.0 specification. Some of the more interesting information thereof is the life time estimation and pre EOL information as follows: root@apalis-t30:~# mmc extcsd read /dev/mmcblk0 | \ grep -A 3 'Device life time estimation type A' Device life time estimation type A [DEVICE_LIFE_TIME_EST_TYP_A: 0x01] i.e. 0% - 10% device life time used Pre EOL information [PRE_EOL_INFO: 0x01] i.e. Normal
Diffstat (limited to 'recipes-devtools/mmc/mmc-utils_chromiumos.bb')
-rw-r--r--recipes-devtools/mmc/mmc-utils_chromiumos.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/mmc/mmc-utils_chromiumos.bb b/recipes-devtools/mmc/mmc-utils_chromiumos.bb
new file mode 100644
index 0000000..54dcaca
--- /dev/null
+++ b/recipes-devtools/mmc/mmc-utils_chromiumos.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Userspace tools for MMC/SD devices"
+HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0"
+
+BRANCH ?= "master"
+SRCREV = "eb1cd019c6ad425633a509ab3578e59d5c9ebbc5"
+
+PV = "0.1"
+
+SRC_URI = "git://chromium.googlesource.com/chromiumos/third_party/mmc-utils.git;protocol=https;branch=${BRANCH} \
+ file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mmc ${D}${bindir}
+}