summaryrefslogtreecommitdiff
path: root/recipes-core/usb-rndis/usb-rndis-systemd.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-03-10 16:21:19 +0100
committerStefan Agner <stefan.agner@toradex.com>2015-03-10 16:26:24 +0100
commit5ee8851ace245058551885dddb23a3820f6c2bea (patch)
tree8f1a7bcbcb0345e2724756dcf57b482ac6060a91 /recipes-core/usb-rndis/usb-rndis-systemd.bb
parent0891eabdad215a5504b96cf3af0ba0abd7c358e6 (diff)
usb-rndis: fix various issues with dhcpd service for RNDIS
- Make sure leases file is not persistent (in /var/run now) This allows to serve the same IP to the generated (and hence different IP addresses) - Start RNDIS service after the network.target - Tegra: Add extra service for udhcpd. When running dhcpd directly from udev, the daemon will be killed after a while
Diffstat (limited to 'recipes-core/usb-rndis/usb-rndis-systemd.bb')
-rw-r--r--recipes-core/usb-rndis/usb-rndis-systemd.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-core/usb-rndis/usb-rndis-systemd.bb b/recipes-core/usb-rndis/usb-rndis-systemd.bb
index 5e6a728..d229123 100644
--- a/recipes-core/usb-rndis/usb-rndis-systemd.bb
+++ b/recipes-core/usb-rndis/usb-rndis-systemd.bb
@@ -1,5 +1,5 @@
SECTION = "network"
-DESCRIPTION = "RNDIS usb client configuration and startup"
+SUMMARY = "RNDIS usb client configuration and startup"
RDEPENDS_${PN} = ""
# The license is meant for this recipe and the files it installs.
# RNDIS is part of the kernel, udhcpd is part of busybox
@@ -31,6 +31,7 @@ SRC_URI = " \
SRC_URI_tegra = " \
${SRC_URI_COMMON} \
file://usb-rndis.rules \
+ file://usb-rndis-udhcpd.service \
"
do_install() {
@@ -45,10 +46,13 @@ do_install() {
do_install_append_tegra() {
install -d ${D}/${sysconfdir}/udev/rules.d
install -m 0644 ${WORKDIR}/usb-rndis.rules ${D}/${sysconfdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/usb-rndis-udhcpd.service ${D}${systemd_unitdir}/system
}
+FILES_${PN} += "${systemd_unitdir}/system"
+
NATIVE_SYSTEMD_SUPPORT = "1"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "usb-rndis.service"
-SYSTEMD_AUTO_ENABLE = "disable"
+SYSTEMD_AUTO_ENABLE_mx6 = "disable"