summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:20:23 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:20:23 +0100
commit28f05995a6af0650ab1ab590b9187e8309c578cd (patch)
treeafa1f8b851ded5973ec788ff6d41365cc624f42c
parent173ca7bdbaa110a8ae7525ead01c340077cefe7c (diff)
apalis/colibri_t30: latest u-boot git migrated to cbootimage/tegrarcm
Use latest U-Boot from git. Migrate to using cbootimage and tegrarcm.
-rw-r--r--conf/machine/apalis-t30.conf2
-rw-r--r--conf/machine/colibri-t30.conf2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb28
-rw-r--r--recipes/images/files/apalis-t30/burnflash.tar.bz2bin674088 -> 8593 bytes
-rw-r--r--recipes/images/files/colibri-t30/burnflash.tar.bz2bin674513 -> 8823 bytes
-rw-r--r--recipes/images/trdx-image-fstype.inc53
6 files changed, 55 insertions, 30 deletions
diff --git a/conf/machine/apalis-t30.conf b/conf/machine/apalis-t30.conf
index 32fc942..49dab92 100644
--- a/conf/machine/apalis-t30.conf
+++ b/conf/machine/apalis-t30.conf
@@ -11,7 +11,7 @@ KERNEL_IMAGETYPE = "uImage"
PREFERRED_PROVIDER_u-boot = "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex"
-UBOOT_MACHINE = "apalis_t30_config"
+UBOOT_MACHINE = "apalis_t30_defconfig"
UBOOT_ENTRYPOINT = "0x82008000"
UBOOT_LOADADDRESS = "${UBOOT_ENTRYPOINT}"
KEEPUIMAGE = ""
diff --git a/conf/machine/colibri-t30.conf b/conf/machine/colibri-t30.conf
index 35465dc..e9ceaea 100644
--- a/conf/machine/colibri-t30.conf
+++ b/conf/machine/colibri-t30.conf
@@ -11,7 +11,7 @@ KERNEL_IMAGETYPE = "uImage"
PREFERRED_PROVIDER_u-boot = "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex"
-UBOOT_MACHINE = "colibri_t30_config"
+UBOOT_MACHINE = "colibri_t30_defconfig"
UBOOT_ENTRYPOINT = "0x82008000"
UBOOT_LOADADDRESS = "${UBOOT_ENTRYPOINT}"
KEEPUIMAGE = ""
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index ceb5199..4651b85 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -4,8 +4,9 @@ PROVIDES = "u-boot"
DEPENDS += "dtc-native"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+LIC_FILES_CHKSUM_colibri-t20 = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
+LIC_FILES_CHKSUM_tegra3 = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
@@ -15,27 +16,34 @@ DEFAULT_PREFERENCE_apalis-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-# This revision is based on upstream "v2011.06"
-SRCREV_COLIBRI = "278ca22a59e3df4dd1e1494e8920a01c172118af"
+SRC_URI_T20 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
+SRC_URI_T30 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2014.10-toradex"
+# This revision is based on upstream "v2014.10"
+SRCREV_T20 = "278ca22a59e3df4dd1e1494e8920a01c172118af"
+SRCREV_T30 = "67c3a4aee6c0af124ce779aed1be70c7a92d0916"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
PV_apalis-t30 = "${PR}+gitr${SRCREV}"
-SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
-SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
-SRC_URI_apalis-t30 = "${SRC_URI_COLIBRI}"
+SRC_URI_colibri-t20 = "${SRC_URI_T20}"
+SRC_URI_colibri-t30 = "${SRC_URI_T30}"
+SRC_URI_apalis-t30 = "${SRC_URI_T30}"
-SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
-SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
-SRCREV_apalis-t30 = "${SRCREV_COLIBRI}"
+SRCREV_colibri-t20 = "${SRCREV_T20}"
+SRCREV_colibri-t30 = "${SRCREV_T30}"
+SRCREV_apalis-t30 = "${SRCREV_T30}"
# override the solution passed in from u-boot.inc as we want to set additional flags
EXTRA_OEMAKE_colibri-t20 = "CROSS_COMPILE=${TARGET_PREFIX}"
EXTRA_OEMAKE_colibri-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
EXTRA_OEMAKE_apalis-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
+# apalis/colibri-t30: require u-boot-dtb-tegra.bin to be used
+UBOOT_IMAGE_tegra3 = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY_tegra3 = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK_tegra3 = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
+
# colibri-t20: build additionally a u-boot binary which uses/stores its environment on an T20 external sd or mmc card
SPL_BINARY_colibri-t20 = "u-boot-hsmmc.bin"
SPL_IMAGE_colibri-t20 = "u-boot-hsmmc-${MACHINE}-${PV}-${PR}.bin"
diff --git a/recipes/images/files/apalis-t30/burnflash.tar.bz2 b/recipes/images/files/apalis-t30/burnflash.tar.bz2
index d69ac83..e47802f 100644
--- a/recipes/images/files/apalis-t30/burnflash.tar.bz2
+++ b/recipes/images/files/apalis-t30/burnflash.tar.bz2
Binary files differ
diff --git a/recipes/images/files/colibri-t30/burnflash.tar.bz2 b/recipes/images/files/colibri-t30/burnflash.tar.bz2
index 9f10174..e764d35 100644
--- a/recipes/images/files/colibri-t30/burnflash.tar.bz2
+++ b/recipes/images/files/colibri-t30/burnflash.tar.bz2
Binary files differ
diff --git a/recipes/images/trdx-image-fstype.inc b/recipes/images/trdx-image-fstype.inc
index dbafc48..c31b4c2 100644
--- a/recipes/images/trdx-image-fstype.inc
+++ b/recipes/images/trdx-image-fstype.inc
@@ -6,16 +6,45 @@ IMAGE_ROOTFS = "${WORKDIR}/${IMAGE_NAME}${PV}/rootfs"
U_BOOT_EXT = "bin"
U_BOOT_EXT_vf = "imx"
U_BOOT_EXT_mx6 = "imx"
+U_BOOT_SYMLINK = "u-boot-${MACHINE}.${U_BOOT_EXT}"
+U_BOOT_SYMLINK_tegra3 = "u-boot-dtb-tegra-${MACHINE}.${U_BOOT_EXT}"
+U_BOOT_BINARY = "u-boot.${U_BOOT_EXT}"
+U_BOOT_BINARY_tegra3 = "u-boot-dtb-tegra.${U_BOOT_EXT}"
#we need some native tools for deployment
-DEPENDS_append_colibri-vf = " mtd-utils-native imx-loader-native"
DEPENDS_append_mx6 = " imx-loader-native"
+DEPENDS_append_tegra3 = " cbootimage-native tegrarcm-native"
+DEPENDS_append_vf = " mtd-utils-native imx-loader-native"
imagedeploytools() {
# default to nothing to deploy
:
}
-imagedeploytools_colibri-vf() {
+
+imagedeploytools_append_mx6() {
+ IMAGE_ROOT="${IMAGE_ROOTFS}/../imx_flash/"
+ rm -f ${IMAGE_ROOT}/imx_flash/imx_usb ${IMAGE_ROOT}/imx_flash/*.conf
+ mkdir -p ${IMAGE_ROOT}
+
+ # add imx-loader and its configuration files
+ cp ${STAGING_BINDIR_NATIVE}/imx_usb ${IMAGE_ROOT}/
+ ${BUILD_STRIP} ${IMAGE_ROOT}/imx_usb ${IMAGE_ROOT}/imx_usb.m32
+ cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/imx_usb.conf ${IMAGE_ROOT}/
+ cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/mx6_usb_work.conf ${IMAGE_ROOT}/
+}
+
+imagedeploytools_append_tegra3() {
+ IMAGE_ROOT="${IMAGE_ROOTFS}/../tegra-uboot-flasher/"
+ mkdir -p ${IMAGE_ROOT}
+
+ # add cbootimage and tegrarcm
+ cp ${STAGING_BINDIR_NATIVE}/cbootimage ${IMAGE_ROOT}/
+ cp ${STAGING_BINDIR_NATIVE}/tegrarcm ${IMAGE_ROOT}/
+ ${BUILD_STRIP} ${IMAGE_ROOT}/cbootimage
+ ${BUILD_STRIP} ${IMAGE_ROOT}/tegrarcm
+}
+
+imagedeploytools_append_vf() {
IMAGE_ROOT="${IMAGE_ROOTFS}/../vf_flash/"
rm -f ${IMAGE_ROOT}/mkfs.ubifs ${IMAGE_ROOT}/imx_uart
mkdir -p ${IMAGE_ROOT}
@@ -30,27 +59,15 @@ imagedeploytools_colibri-vf() {
cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/vybrid_usb_work.conf ${IMAGE_ROOT}/
}
-imagedeploytools_append_mx6() {
- IMAGE_ROOT="${IMAGE_ROOTFS}/../imx_flash/"
- rm -f ${IMAGE_ROOT}/imx_flash/imx_usb ${IMAGE_ROOT}/imx_flash/*.conf
- mkdir -p ${IMAGE_ROOT}
-
- # add imx-loader and its configuration files
- cp ${STAGING_BINDIR_NATIVE}/imx_usb ${IMAGE_ROOT}/
- ${BUILD_STRIP} ${IMAGE_ROOT}/imx_usb ${IMAGE_ROOT}/imx_usb.m32
- cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/imx_usb.conf ${IMAGE_ROOT}/
- cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/mx6_usb_work.conf ${IMAGE_ROOT}/
-}
-
imagedeploy_kernel() {
# put u-boot, kernel into the bin directories, remove the kernel/dtb from the rootfs/boot
- # rm -f ${IMAGE_ROOTFS}/boot/uImage* ${IMAGE_ROOTFS}/boot/*.dtb
+ rm -f ${IMAGE_ROOTFS}/boot/uImage* ${IMAGE_ROOTFS}/boot/*.dtb
cp -pP ${DEPLOY_DIR_IMAGE}/uImage* ${IMAGE_ROOTFS}/../${MACHINE}_bin/
ls ${DEPLOY_DIR_IMAGE}/*.dtb 2> /dev/null && cp -pP ${DEPLOY_DIR_IMAGE}/*.dtb ${IMAGE_ROOTFS}/../${MACHINE}_bin/
mv ${IMAGE_ROOTFS}/../${MACHINE}_bin/uImage-${MACHINE}.bin ${IMAGE_ROOTFS}/../${MACHINE}_bin/uImage
}
-imagedeploy_kernel_colibri-vf() {
+imagedeploy_kernel_vf() {
# Do nothing, we use the kernel from /boot inside root fs
:
}
@@ -64,7 +81,7 @@ fakeroot do_imagedeploy() {
cp -pP ${DEPLOY_DIR_IMAGE}/u-boot* ${IMAGE_ROOTFS}/../${MACHINE}_bin/
rm -f ${IMAGE_ROOTFS}/../${MACHINE}_bin/u-boot-hsmmc-${MACHINE}.${U_BOOT_EXT}
- mv ${IMAGE_ROOTFS}/../${MACHINE}_bin/u-boot-${MACHINE}.${U_BOOT_EXT} ${IMAGE_ROOTFS}/../${MACHINE}_bin/u-boot.${U_BOOT_EXT}
+ mv ${IMAGE_ROOTFS}/../${MACHINE}_bin/${U_BOOT_SYMLINK} ${IMAGE_ROOTFS}/../${MACHINE}_bin/${U_BOOT_BINARY}
# add the rootfs version to the welcome banner
echo "${IMAGE_NAME}${PV}_${DATE}" >> ${IMAGE_ROOTFS}/etc/issue
@@ -81,4 +98,4 @@ fakeroot do_imagedeploy() {
tar -cjf ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${PV}_${DATE}.tar.bz2 ${IMAGE_NAME}${PV}
}
-addtask imagedeploy after do_rootfs before do_rm_work
+addtask imagedeploy after do_rootfs before do_build