summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-03-29 12:28:59 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-01 10:11:35 +0200
commit7f60c973634b55fbda297d2408c94890ca1ae399 (patch)
tree5b7202a84b8577a9429d9ccc71b39f08439c6051
parent273c7ab06f5f6af5a552fb932405cd9282dadcd7 (diff)
u-boot: convert bbappend to a bb
-rw-r--r--recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend17
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb (renamed from recipes-bsp/u-boot/u-boot_2011.06.bbappend)17
2 files changed, 11 insertions, 23 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend b/recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend
deleted file mode 100644
index 51482df..0000000
--- a/recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
-# Extends the core u-boot recipe
-# to take the u-boot sources including the colibri stuff from our git repository
-PR ="r7"
-COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
-
-DEFAULT_PREFERENCE_colibri-t20 = "1"
-
-FILESPATHPKG =. "git:"
-S="${WORKDIR}/git"
-SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRCREV_COLIBRI = "d7fcf63504425a73f74f3d1d2f5ba68533280ff4"
-
-PV_colibri-t20 = "${PR}+gitr${SRCREV}"
-
-SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
-SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
-PV_colibri-t20 = "${PR}+gitr${SRCREV}"
diff --git a/recipes-bsp/u-boot/u-boot_2011.06.bbappend b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index ae9a82b..b3e06d2 100644
--- a/recipes-bsp/u-boot/u-boot_2011.06.bbappend
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -1,9 +1,11 @@
-# Extends the core u-boot recipe
-# to take the u-boot sources including the colibri stuff from our git repository
-PR ="r7"
+require recipes-bsp/u-boot/u-boot.inc
+
+PROVIDES = "u-boot"
DEPENDS += "dtc-native"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
COMPATIBLE_MACHINE_colibri-t30 = "colibri-t30"
@@ -16,7 +18,8 @@ DEFAULT_PREFERENCE_apalis-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-#SRC_URI_COLIBRI += "file://u-boot-dont-build-standalone.patch"
+SRC_URI_COLIBRI += "file://u-boot-dont-build-standalone.patch"
+# This revision is based on upstream "v2011.06"
SRCREV_COLIBRI = "ccd521c4681a5850bbec1feec140eeaec33936b0"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
@@ -51,3 +54,5 @@ do_compile_append_colibri-t20() {
#do_install_append() {
#}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"