summaryrefslogtreecommitdiff
path: root/recipes-core/nv-conf/nv-conf-systemd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/nv-conf/nv-conf-systemd.bb')
-rw-r--r--recipes-core/nv-conf/nv-conf-systemd.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-core/nv-conf/nv-conf-systemd.bb b/recipes-core/nv-conf/nv-conf-systemd.bb
new file mode 100644
index 0000000..c592bc3
--- /dev/null
+++ b/recipes-core/nv-conf/nv-conf-systemd.bb
@@ -0,0 +1,32 @@
+SECTION = "sysinit"
+SUMMARY = "NVIDIA T30 CPU hot-plug configuration and startup"
+RDEPENDS_${PN} = ""
+# The license is meant for this recipe and the files it installs.
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+
+PR = "r1"
+
+inherit allarch systemd
+
+SRC_URI = " \
+ file://nv-conf.sh \
+ file://nv-conf.service \
+"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/nv-conf.sh ${D}/${bindir}/
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/nv-conf.service ${D}${systemd_unitdir}/system
+}
+
+FILES_${PN} += " \
+ ${systemd_unitdir}/system \
+"
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "nv-conf.service"
+