summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/files/fw_unlock_mmc.sh6
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb9
2 files changed, 8 insertions, 7 deletions
diff --git a/recipes-bsp/u-boot/files/fw_unlock_mmc.sh b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
index 8982640..f9f253b 100644
--- a/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
+++ b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
@@ -1,6 +1,6 @@
-# Give fw_setenv mmcblk0boot1 write permissions
+# Give fw_setenv mmcblk0boot0 write permissions
function fw_setenv() {
- echo 0 > /sys/block/mmcblk0boot1/force_ro
+ echo 0 > /sys/block/mmcblk0boot0/force_ro
/sbin/fw_setenv "$@"
- echo 1 > /sys/block/mmcblk0boot1/force_ro
+ echo 1 > /sys/block/mmcblk0boot0/force_ro
}
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 959860d..0f65b22 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -18,7 +18,8 @@ SRCREV = "06ee8db6422e02337242e43b8573359443db59ea"
SRCBRANCH = "2015.04-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
- file://fw_unlock_mmc.sh \
+"
+SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh \
"
PV_apalis-t30 = "${PR}+gitr${SRCREV}"
@@ -65,11 +66,11 @@ pkg_postinst_${PN}_tegra3 () {
if [ "x$D" != "x" ]; then
exit 1
fi
- # Environment in eMMC, at the end of 2nd "boot sector"
- DISK="mmcblk0boot1"
+ # Environment in eMMC, before the configblock at the end of 1st "boot sector"
+ DISK="mmcblk0boot0"
DISK_SIZE=`cat /sys/block/$DISK/size`
CONFIG_ENV_SIZE=8192 # 0x2000
- CONFIG_ENV_OFFSET=`expr $DISK_SIZE \* 512 - $CONFIG_ENV_SIZE`
+ CONFIG_ENV_OFFSET=`expr $DISK_SIZE \* 512 - $CONFIG_ENV_SIZE - 512`
printf "/dev/%s\t0x%X\t0x%X\n" $DISK $CONFIG_ENV_OFFSET $CONFIG_ENV_SIZE >> "/etc/fw_env.config"
}