summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-01-26 19:07:22 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:09:11 +0200
commitc724da634301598ba36acb7ae1933b5caf7184a8 (patch)
treeb60787963cbf3d5ad01fb20071b71eff83dfb9d3 /recipes-kernel/linux/linux-toradex-mainline_4.9.bb
parente04e355523a00c5d6b2872b2398144f54b667381 (diff)
linux: remove bashism from do_configure
pushd and popd are not posix compliant. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-kernel/linux/linux-toradex-mainline_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_4.9.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline_4.9.bb b/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
index f0ff5fe..b04f29a 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
@@ -39,7 +39,7 @@ config_script () {
}
do_configure_prepend () {
- pushd ${S}
+ cd ${S}
export KBUILD_OUTPUT=${B}
oe_runmake ${KERNEL_DEFCONFIG}
@@ -50,7 +50,7 @@ do_configure_prepend () {
sed -i -e /CONFIG_LOCALVERSION/d ${B}/.config
echo "CONFIG_LOCALVERSION=\"${LOCALVERSION}\"" >> ${B}/.config
- popd
+ cd - > /dev/null
}
do_uboot_mkimage_prepend() {