summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-02-03 14:15:06 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2014-02-04 10:59:00 +0100
commit0197a768cbad0aaa4b2823d91e99cfff596ef17b (patch)
tree069a23f8c6816282ba71b80f05a4f33d5cb2ed47
parentd46e9fb08a089e6d34c411d627da12768845de42 (diff)
util-linux: add fstrim
Add the fstrim utility to Colibri T30 image. The utility allows to send trim commands to the underlaying flash translation layer, which allows too free not used flash sectors and those improve wear- leveling
-rw-r--r--recipes-core/util-linux/util-linux_2.22.2.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-core/util-linux/util-linux_2.22.2.bbappend b/recipes-core/util-linux/util-linux_2.22.2.bbappend
new file mode 100644
index 0000000..d3f8ca2
--- /dev/null
+++ b/recipes-core/util-linux/util-linux_2.22.2.bbappend
@@ -0,0 +1,12 @@
+#backport from master, util-linux: Add fstrim utility, commit ee3599472d7c5ccbf259312c7622b982941b6b1e
+
+PRINC := "${@int(PRINC) + 2}"
+
+PACKAGES =+ "util-linux-fstrim"
+FILES_util-linux-fstrim = "${base_sbindir}/fstrim"
+
+do_install_append () {
+ if [ -f "${D}${sbindir}/fstrim" ]; then
+ mv "${D}${sbindir}/fstrim" "${D}${base_sbindir}/fstrim"
+ fi
+}