summaryrefslogtreecommitdiff
path: root/recipes-support/bmode-usb/bmode-usb_1.0.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-05-01 17:23:13 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-06-09 17:20:21 +0200
commite7fcc273dc0d44145083f131d242424135fe2e53 (patch)
treec7beb97c805be3dae2d496de1545e622f7dc2fce /recipes-support/bmode-usb/bmode-usb_1.0.bb
parentd351e11b76c004afbf0f37d5481266bafdb015ee (diff)
bmode-usb: add recipe to set i.mx 6 boot mode
This linux userspace tool does what U-Boot's 'bmode usb noreset' does. On the next reboot the i.MX 6 will boot to recovery aka serial download mode. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-support/bmode-usb/bmode-usb_1.0.bb')
-rw-r--r--recipes-support/bmode-usb/bmode-usb_1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-support/bmode-usb/bmode-usb_1.0.bb b/recipes-support/bmode-usb/bmode-usb_1.0.bb
new file mode 100644
index 0000000..f33f531
--- /dev/null
+++ b/recipes-support/bmode-usb/bmode-usb_1.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Sets i.MX boot mode on next reboot to recovery, aka serial download"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://bmode_usb.c;endline=5;md5=4c9010cb42fb7648a460c35e6b5c685c"
+
+SRC_URI = "file://bmode_usb.c"
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} -o bmode_usb bmode_usb.c ${CFLAGS} ${LDFLAGS}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install bmode_usb ${D}${bindir}
+}