summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex-rt_3.14.28.bb
diff options
context:
space:
mode:
authorBrandon Shibley <brandon.shibley@toradex.com>2016-03-23 15:10:48 -0700
committerMax Krummenacher <max.krummenacher@toradex.com>2016-03-30 18:07:26 +0200
commit3527f16741e49e0e07e7b5e329aa40dc81280f08 (patch)
treef41ac2e7f89a93832f1f0e6855b29665cbf1c9bb /recipes-kernel/linux/linux-toradex-rt_3.14.28.bb
parent35e4f6a626cbd86fdfc4e9375d9a7d4dad02fcfe (diff)
linux-toradex-fsl-rt: Added a real-time kernel recipe
A new i.MX6 real-time kernel recipe was added with a modified PREEMPT_RT patch to accomodate the backports applied to the Toradex kernel. To select the kernel use a preferred provider variable in your configuration files (e.g. local.conf): PREFERRED_PROVIDER_virtual/kernel = "linux-toradex-fsl-rt" Signed-off-by: Brandon Shibley <brandon.shibley@toradex.com> Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-kernel/linux/linux-toradex-rt_3.14.28.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex-rt_3.14.28.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-rt_3.14.28.bb b/recipes-kernel/linux/linux-toradex-rt_3.14.28.bb
new file mode 100644
index 0000000..cd136a4
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-rt_3.14.28.bb
@@ -0,0 +1,23 @@
+require recipes-kernel/linux/linux-imx.inc
+require recipes-kernel/linux/linux-dtb.inc
+
+SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
+
+SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH} \
+ file://0001-ARM-imx6q-drop-unnecessary-semicolon.patch \
+ file://0002-ARM-clk-imx6q-fix-video-divider-for-rev-T0-1.0.patch \
+ file://0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch \
+ file://0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch \
+ file://0005-Revert-net-fec-fix-the-warning-found-by-dma-debug.patch \
+ file://patch-3.14.28-rt25-acpi-removed.patch.gz \
+ file://0001-fix-build.patch \
+ file://0002-fix-build-with-rt-enabled.patch \
+ file://0003-no-split-ptlocks.patch \
+ file://0004-imx-sdma-channel-use-raw-spinlock.patch \
+ file://defconfig"
+
+LOCALVERSION = "-v2.6b1-rt"
+SRCBRANCH = "toradex_imx_3.14.28_1.0.0_ga"
+SRCREV = "0bb38d19090dc611c8bc9c18e770620c73f7563c"
+DEPENDS += "lzop-native bc-native"
+COMPATIBLE_MACHINE = "(mx6)"