summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend14
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 7a385c0..223eb2c 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -5,15 +5,19 @@ SRC_URI += "file://toradex-save-touchscreen-calibration.sh"
PACKAGECONFIG[touchscreen-calibration] = ",,"
PACKAGECONFIG:append:tdx = " touchscreen-calibration"
-INI_UNCOMMENT_ASSIGNMENTS:append:tdx = " \
- \\[libinput\\] \
- enable_tap=true \
-"
-
do_install:append:tdx() {
if [ "${@bb.utils.contains('PACKAGECONFIG', 'touchscreen-calibration', 'yes', 'no', d)}" = "yes" ]; then
+ sed -i -e "s/^#\\[libinput\\]/[libinput]/g" ${D}${sysconfdir}/xdg/weston/weston.ini
+
+ sed -i -e "/calibration_helper=/d" ${D}${sysconfdir}/xdg/weston/weston.ini
sed -i -e "/^\[libinput\]/a calibration_helper=${bindir}/toradex-save-touchscreen-calibration" ${D}${sysconfdir}/xdg/weston/weston.ini
+
+ sed -i -e "/touchscreen_calibrator=/d" ${D}${sysconfdir}/xdg/weston/weston.ini
sed -i -e "/^\[libinput\]/a touchscreen_calibrator=true" ${D}${sysconfdir}/xdg/weston/weston.ini
+
+ sed -i -e "/enable_tap=/d" ${D}${sysconfdir}/xdg/weston/weston.ini
+ sed -i -e "/^\[libinput\]/a enable_tap=true" ${D}${sysconfdir}/xdg/weston/weston.ini
+
install -Dm0755 ${WORKDIR}/toradex-save-touchscreen-calibration.sh ${D}${bindir}/toradex-save-touchscreen-calibration
fi
}