summaryrefslogtreecommitdiff
path: root/freertos/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Sliwa <dominik.sliwa@toradex.com>2018-10-31 11:52:09 +0100
committerDominik Sliwa <dominik.sliwa@toradex.com>2018-10-31 12:15:31 +0100
commit11ceeadccd30e1985eaf85b6cd46cf04c846a8d9 (patch)
treee75a2cfd5d8507ca2abe6af13d8316a226842958 /freertos/CMakeLists.txt
parent8f8aba14840284af44c6e7ce6ea8600d3cf2327f (diff)
Update to FreeRTOS 10.1.1
Signed-off-by: Dominik Sliwa <dominik.sliwa@toradex.com>
Diffstat (limited to 'freertos/CMakeLists.txt')
-rw-r--r--freertos/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/freertos/CMakeLists.txt b/freertos/CMakeLists.txt
index 23eb791..bb81dd9 100644
--- a/freertos/CMakeLists.txt
+++ b/freertos/CMakeLists.txt
@@ -5,11 +5,10 @@ list(APPEND SOURCES
${CMAKE_CURRENT_LIST_DIR}/src/event_groups.c
${CMAKE_CURRENT_LIST_DIR}/src/list.c
${CMAKE_CURRENT_LIST_DIR}/src/queue.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/stream_buffer.c
${CMAKE_CURRENT_LIST_DIR}/src/tasks.c
${CMAKE_CURRENT_LIST_DIR}/src/timers.c
${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/port.c
- ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/fsl_tickless_systick.c
- ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/fsl_tickless_lptmr.c
# include the specified heap allocator
${CMAKE_CURRENT_LIST_DIR}/src/portable/MemMang/heap_${FREERTOS_HEAP_ALLOCATOR}.c
)